Jump to content
Sign in to follow this  
HarryAdney

configproducts.php has no css

Recommended Posts

My configproducts.php page (Setup>Products/Services>Products/Services) is missing it's css since the 7.8.0 upgrade. Checking the source code, it seems the header and footer includes are missing. 

I've checked a few other pages, which are unaffected. Any suggestions?

 

Many thanks.

whmcs-configproducts_php-screenshot.png

Share this post


Link to post
Share on other sites

Hi @HarryAdney,

Please start your troubleshooting by following these steps: https://help.whmcs.com/m/troubleshooting/l/678235-troubleshooting-a-blank-page-oops-error-message

Likely an after-market customisation is causing a problem, and should be detailed on-screen with Display Errors enabled.

It might also be worth checking Utilities > Logs > Activity Log for any template syntax errors.

Share this post


Link to post
Share on other sites
On 8/30/2019 at 8:50 PM, WHMCS John said:

Hi @HarryAdney,

Please start your troubleshooting by following these steps: https://help.whmcs.com/m/troubleshooting/l/678235-troubleshooting-a-blank-page-oops-error-message

Likely an after-market customisation is causing a problem, and should be detailed on-screen with Display Errors enabled.

It might also be worth checking Utilities > Logs > Activity Log for any template syntax errors.

Thanks John.

I've enabled the errors, but the page is exactly the same. I always assumed the website was affected by the errors setting, rather than WHMCS itself.

I've opened the activity log and it's taking a long time to load. Apparently there are 7128493 records in 142570 pages! It also seems to have knocked my site offline - it's showing a 503 error now.

I did set the "limit activity log" to 10000 originally, so I haven't a clue why it should be 7128493 now.

Wondering if I should reinstall... or maybe go be a window cleaner lol.

Share this post


Link to post
Share on other sites
11 hours ago, HarryAdney said:

I did set the "limit activity log" to 10000 originally, so I haven't a clue why it should be 7128493 now. 

that limit only applies to "System" tasks...

Quote

  System related entries are those where the user shows as System and associated to UserID 0. Entries attributed to specific clients will be kept indefinitely for auditing purposes. Client specific log entries can be pruned via Utilities > System > System Cleanup.

I think most of the log entries now are assigned to the admin user, so that could explain why it's so large.

11 hours ago, HarryAdney said:

Wondering if I should reinstall...

there is a v7.8.1 maintenance release available.... although I suppose in your case, you'd be better off getting the full install zip and using that instead of getting the incremental patch or automatic updater.

Share this post


Link to post
Share on other sites
11 hours ago, HarryAdney said:

Thanks John.

I've enabled the errors, but the page is exactly the same. I always assumed the website was affected by the errors setting, rather than WHMCS itself.

I've opened the activity log and it's taking a long time to load. Apparently there are 7128493 records in 142570 pages! It also seems to have knocked my site offline - it's showing a 503 error now.

I did set the "limit activity log" to 10000 originally, so I haven't a clue why it should be 7128493 now.

Wondering if I should reinstall... or maybe go be a window cleaner lol.

The error you're experiencing tells us a fatal error is occurring when attempting to load one of the custom or 3rd party modules that your products are configured to use.

Enabling error display should have caused an error to be displayed, however, it could be getting hidden from view in the browser output due to broken HTML.  Best thing to do is probably open a ticket so one of our support technicians can take a look.

-Ed

Share this post


Link to post
Share on other sites

Hey guys, many thanks for your help.

I've asked the team to get me the current full zip file and I'll reinstall. Is it safe to reinstall over the current installation? I know it probably isn't ideal, but...

Share this post


Link to post
Share on other sites

Hi Harry,

Yes it's perfectly safe to re-upload and replace all the files in an existing WHMCS installation with those from a latest zip file download from our website. We recommend doing this from time to time in support to ensure that all files present for an installation are the latest versions. That is assuming that any customisations to templates have been made in a custom template directory (https://developers.whmcs.com/themes/getting-started/), or modifications to files such as language files or whois servers have been made using overrides (https://developers.whmcs.com/languages/overrides/).

-Ed

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By cameronelsea
      I can get to my admin area fine, however, whenever I click the settings button to try and edit my general settings and what not, it redirects me to my home page.
    • By Mechanic
      HI,
      In WHMCS 7.8.3 + 2Checkout payment gateway, the discount is being applied twice when a client tries to create a recurring subscription.
      This does not happen when they try to make a one off payment.
      This can be reproduced by creating a similar invoice under any other client account.
       
    • By Luthersites
      When I try to do the update I get the following error:
      Unable to complete incremental updates: Unable to import the 7.8.0 Alpha1 database file. Unable to import /home/lutherh/public_html/resources/sql/upgrade780alpha1.sql: SQLSTATE[42000]: Syntax error or access violation: 1118 Row size too large. The maximum row size for the used table type, not counting BLOBs, is 8126. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs
      I can't find anything on your site that talks about this error, and I find it odd that the database has incorrectly set column types.  Please advise as to what I need to do.
    • By zarvis
      Hi,
       
      From today morning the Invoices are not being updated, and the API callback is getting failed for the Coingate and perfect money modules.
      Anyone else facing similar issue?
       
      Regards
      Chandrakant
    • By loopmail
      Looking around and some clients have enabled 2fa for the primary user, but there seem to be no details for it on the contacts page. is this not a feature on offer to contacts or a way for administrators to see the status/clear the status for contacts?

       
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated