Jump to content
adtastichosting

Cannot save product descriptions

Recommended Posts

I have 6.3.0. if I try to save a product description that has particular characters, namely quotes (") and then hit save the page is then just empty. I have to reinput the content without using quotes for it to save. Any ideas on this?

Share this post


Link to post
Share on other sites
12 minutes ago, adtastichosting said:

I have 6.3.0. if I try to save a product description that has particular characters, namely quotes (") and then hit save the page is then just empty. I have to reinput the content without using quotes for it to save. Any ideas on this?

quickly tried it on v6.3.1, but couldn't reproduct the issue.

can you get around it by using " instead of " ??

Share this post


Link to post
Share on other sites

no, that doesn't work. Also if I use a : weird things happen it rearranges the content and the section that has the : is now at the top and highlighted. So as a workaround I have to use a dash.

Share this post


Link to post
Share on other sites

Hello,

Please make sure the System Charset under Setup > General Settings > Localisation tab is set to utf-8 and the configuration.php file has this line:

$mysql_charset = 'utf8';

Without those, you may see some weird issues with saving data due to how MySQL works by default with latin1 instead of utf-8.

Share this post


Link to post
Share on other sites

thanks. this was in the localization tab:  iso-8859-1. not sure how that got there. but changing it to utf-8 seems to have fixed the issue. nothing in the config file but do I really need it there now it is working?

Share this post


Link to post
Share on other sites

Most likely it was probably set a long time ago and only noticed now. As for the line in the configuration.php file, I'd strongly recommend adding it - otherwise it can lead to other unexpected issues with saving data.

Share this post


Link to post
Share on other sites
4 hours ago, adtastichosting said:

Also if I use a : weird things happen it rearranges the content and the section that has the : is now at the top and highlighted. So as a workaround I have to use a dash.

this is a known feature...

https://docs.whmcs.com/Standard_Order_Form_Templates#Feature_Highlights

certainly in v7.7, you can get around that by using : instead and that won't trigger the feature highlight formatting, whereas : would.... you've also got to be careful with URLs in the descriptions and the colon in those links too.

Share this post


Link to post
Share on other sites
30 minutes ago, brian! said:

this is a known feature...

https://docs.whmcs.com/Standard_Order_Form_Templates#Feature_Highlights

certainly in v7.7, you can get around that by using : instead and that won't trigger the feature highlight formatting, whereas : would.... you've also got to be careful with URLs in the descriptions and the colon in those links too. 

As I read it the feature highlight feature requires "feature:" to trigger it. At any rate it appears to be fixed now thanks to quick catch by @Lawrence. At some point I hope to upgrade anyways but its a big task for us since we are so integrated into Reseller Club Mods and have to go thru each one of those too at the same time plus not breaking anything in the meantime.

Share this post


Link to post
Share on other sites
10 hours ago, adtastichosting said:

As I read it the feature highlight feature requires "feature:" to trigger it.

but the colon is the trigger. 🙂

10 hours ago, adtastichosting said:

At any rate it appears to be fixed now thanks to quick catch by @Lawrence.

indeed, localisation db settings occurred to me, but on;y after i'd logged off for the day.

10 hours ago, adtastichosting said:

At some point I hope to upgrade anyways but its a big task for us since we are so integrated into Reseller Club Mods and have to go thru each one of those too at the same time plus not breaking anything in the meantime.

Marco from  resellerclub-mods is one of the good guys and always keeps his stuff updated... though never update WHMCS until you know that you have updates for all your addons available and working, e.g don't update WHMCS and then check for updated versions of the addons.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated