Jump to content

Recommended Posts

Hi all,

Domain lookup invoked from the main index (form submit to domainchecker.php) does not work if captcha type is set to "reCAPTCHA v2" or "Invisible reCAPTCHA" and Captcha Form Protection is set to "Off when logged in". This affects customer who are logged in only and only with WHMCS 7.7.1

These are the settings to reproduce the issue:

1. Goto WHMCS -> Setup -> General Settings -> TAB "Security"
2. Set Captcha Form Protection to "Off when logged in"
3. Select Captcha Type "reCAPTCHA v2" or "Invisible reCAPTCHA"
4. Save the changes

Login as a customer (not as admin on behalf a customer). Goto the main index.php of the WHMCS and make a domain search. This will invoke the domain lookup in cart.php but does not perform the domain search. You need to click the Button "Search" in the cart again.

It only happens when logged in and with Captcha Type "reCAPTCHA v2" or "Invisible reCAPTCHA" selected. If you set Captcha Type to "Default (5 Character Verification Code)", then the domain search will be performed without the need to click the search button in the cart.

Can someone confirm the same issue?

Edited by imaticon
typos

Share this post


Link to post
Share on other sites

Hi there,

This may be due to custom templates which will need updating for the changes in WHMCS 7.7 - If you're experiencing this with the Six template then please get in touch with our support team who will be happy to help.

Share this post


Link to post
Share on other sites
56 minutes ago, imaticon said:

No, clean and fresh install, no modifications.

In which case please raise a ticket with our team and we can investigate why this is not working as expected. 🙂

Share this post


Link to post
Share on other sites

Hi Dan,

I have several times setup a fresh WHMCS installation and all I did is adding just .com to test this behavior.  So what could be different in my fresh install and a fresh install from your end? I would say there is no difference and therefore there is no need to provide access for something you already have at your end ( a fresh whmcs install ).

A Bug report has already been opened which has been converted into a support ticket because the support guy was unable to reproduce it.

As for now, there is one WHMCS user that is confirming the same behavior ( thank you @EvolveWebHosting ).

Maybe I have not explained clear enough what the expected behavior should be?

The main issue here is that you need to click again the Search button in the Cart and this should not happen but it does definitely happen BUT ONLY if you reproduce it as I have explained above with the provided settings.

Have you tried, @Dan ?

 

Share this post


Link to post
Share on other sites

I have taken my time now to make the following:

1. Again a clean install of whmcs 7.7.1

2. Basic setup, system url, mail, gateway, registrar module built in from WHMCS (Resellerclub), and added .com TLD

See your self: https://www.hippovideo.io/video/play/Lhf1HYpDLS9HbtkBzWCuiIXszAZCGvz8TyzPhIaXQKA

For whatever reason, WHMCS support says that they cannot reproduct this with a fresh install 🙄

 

Share this post


Link to post
Share on other sites

From @WHMCS John

Thanks for providing those reproduction steps and video, it's most helpful. I've now been able to replicate this issue on my end, and as such have opened case #CORE-13380 with our developers in order to have this reviewed for future releases. Whilst I cannot provide an estimated time for completion for this, once we resolve cases and push features they are available at our change log, here:

https://changelog.whmcs.com/

I apologize for the inconvenience, and appreciate your patience as we work to resolve this.

Thanks again for taking the time to report your findings. We welcome bug reports at https://bugs.whmcs.com/

Hopefully we'll see a hotfix or a fix by the time they release the next version.

Share this post


Link to post
Share on other sites

Fully understand that this is now an official BUG at WHMCS to get fixed.

But wanted to add +1 this is certainly a bug on my end as well.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated