Jump to content
template trip

How to solve 500 internal server error in my website?

Recommended Posts

My webmaster of website (https://www.templatetrip.com) is detected problem is 500 internal server error,
and i did all type tips and trick use to trying because may be problem solved but problem is not solve
please give me your suggestion because may problem is solve.
TemplateTrip, we develop premium ecommerce web templates

Capture.PNG

Share this post


Link to post
Share on other sites

500 internal server error is a generic error, which means "Something is not working properly ... look at log to see what is it".

Having no access to your server's log it's hard to understand (but I guess that your webmaster should have access to them).

From outside, I can see in browser's console following error:

Uncaught ReferenceError: firebase is not defined
    at (index):22
firebase.js:1 
It looks like you're using the development build of the Firebase JS SDK.
When deploying Firebase apps to production, it is advisable to only import
the individual SDK components you intend to use.

For the CDN builds, these are available in the following manner
(replace <PACKAGE> with the name of a component - i.e. auth, database, etc):

https://www.gstatic.com/firebasejs/5.0.0/firebase-<PACKAGE>.js

(anonymous) @ firebase.js:1
jquery-migrate.min.js:2 JQMIGRATE: Migrate is installed, version 1.4.1
util.js:224 Google Maps JavaScript API warning: NoApiKeys https://developers.google.com/maps/documentation/javascript/error-messages#no-api-keys
Dw.m @ util.js:224
mailchimp-woocommerce-public.min.js:1 queue success

Hope it may be useful...  😉

Share this post


Link to post
Share on other sites

Enable the debugging mode in WHMCS admin that will help you figure out the issue.

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, WGS said:

Enable the debugging mode in WHMCS admin that will help you figure out the issue.

I guess the site is made using WordPress, not WHMCS (even if I don't know why @template trip is asking for help here... )

Edited by Remitur

Share this post


Link to post
Share on other sites
3 hours ago, Remitur said:

I guess the site is made using WordPress, not WHMCS

I think you're right. It's using WooCommerce, and is slow and unfinished.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated