Jump to content
yggdrasil

Disable smartsearch

Recommended Posts

Is there a way to disable the new SmartSearch feature and have it working like it was previously?

Share this post


Link to post
Share on other sites
52 minutes ago, yggdrasil said:

Is there a way to disable the new SmartSearch feature and have it working like it was previously?

still not managed to get it working properly on your updated WHMCS yet ?

theoretically, I suppose if you could take the appropriate js code from your pre-updated version, and replace the equivalent code in the current version, that might work... but that's possibly dependent on the old intelligent search method working with the updated js file.

even though there is an IntelligentSearch hook, I think it only adds access to additional custom search results, not replacing the existing search (e.g the hook results come after the main results) - though if you find the time to play with the hook, I might be wrong.

Share this post


Link to post
Share on other sites
5 hours ago, brian! said:

still not managed to get it working properly on your updated WHMCS yet ?

theoretically, I suppose if you could take the appropriate js code from your pre-updated version, and replace the equivalent code in the current version, that might work... but that's possibly dependent on the old intelligent search method working with the updated js file.

even though there is an IntelligentSearch hook, I think it only adds access to additional custom search results, not replacing the existing search (e.g the hook results come after the main results) - though if you find the time to play with the hook, I might be wrong.

How would I? The errors come from encoded files in the vendors folder. I cannot check or debug that. I just want the old search that worked for me in the past back. Nothing related to the new route paths on Laravel works on my installation. The more WHMCS moves stuff into that framework the more things break on my server.

Share this post


Link to post
Share on other sites
18 hours ago, yggdrasil said:

How would I? The errors come from encoded files in the vendors folder.

not necessarily - as an example, I can invalidate the code within an action hook (on purpose or by accident lol) and it will throw up all sorts of errors in /vendor/illuminate/database/ - but that's not where the problem is, the cause of the errors are the hook not something within vendor itself.

i'm surprised that after an update, and if you are using an updated version of Blend, that you're seeing Intelligent Search errors... for that to occur, there must be legacy files present, and/or hooks etc... I know sentq posted a intelligentsearch hook years ago - you're not still using that are you?

18 hours ago, yggdrasil said:

I just want the old search that worked for me in the past back.

then i'm tempted to say that you really should have tested before updating... if you know you've got a highly modified installation, surely it would have been sensible to dip your toe in the water first?

Share this post


Link to post
Share on other sites
2 hours ago, brian! said:

not necessarily - as an example, I can invalidate the code within an action hook (on purpose or by accident lol) and it will throw up all sorts of errors in /vendor/illuminate/database/ - but that's not where the problem is, the cause of the errors are the hook not something within vendor itself.

i'm surprised that after an update, and if you are using an updated version of Blend, that you're seeing Intelligent Search errors... for that to occur, there must be legacy files present, and/or hooks etc... I know sentq posted a intelligentsearch hook years ago - you're not still using that are you?

then i'm tempted to say that you really should have tested before updating... if you know you've got a highly modified installation, surely it would have been sensible to dip your toe in the water first?

I did. The error was spotted in my dev/test installation but I did not care because its not a hard breaking feature. The client area and other things like billing are working fine, so I gave a green check to move the upgrade to production. For me, not being able to search or something else broken in the admin is not as critical as opposed to issues on customers that need to be fixed intermediately.

Now that you say, I think I did spot some errors related to hooks while triggering a search query. It seems the search wants to use some hooks. I will double check that.

Share this post


Link to post
Share on other sites
On 4/25/2019 at 5:10 PM, brian! said:

not necessarily - as an example, I can invalidate the code within an action hook (on purpose or by accident lol) and it will throw up all sorts of errors in /vendor/illuminate/database/ - but that's not where the problem is, the cause of the errors are the hook not something within vendor itself.

i'm surprised that after an update, and if you are using an updated version of Blend, that you're seeing Intelligent Search errors... for that to occur, there must be legacy files present, and/or hooks etc... I researched this topic at https://edubirdie.com/blog/how-to-write-analytical-essay. I know sentq posted a intelligentsearch hook years ago - you're not still using that are you?

then i'm tempted to say that you really should have tested before updating... if you know you've got a highly modified installation, surely it would have been sensible to dip your toe in the water first?

As I know, the first isn't a rule sometimes. The reason of the problem could be anything. 

  • Disappointing 1

Share this post


Link to post
Share on other sites
On 15/05/2019 at 13:05, JaimeRivera said:

As I know, the first isn't a rule sometimes. The reason of the problem could be anything. 

I don't appreciate new spam links being added, or modifying previously valid links, when quoting me - i'll ask @WHMCS ChrisD to have that link removed. headshake.gif

  • Haha 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated