Jump to content
ebbydare

Paypal error with whmcs

Recommended Posts

Hello mates,

I got the following error from paypal within whmcs while a client was trying to purchase a domain from us.

 

"Things don't appear to be working at the moment. Please try again later."

What do you advise? Thanks

Share this post


Link to post
Share on other sites

@ebbydare please try enabling your error logs under Setup > General Settings > Other > Display Errors & Log Error and Display errors, try replicating the issues and also review the billing log for any further errors

Share this post


Link to post
Share on other sites

Hello one and all,

I'm now seeing the same on my version of WHMCS (7.7.1)

Double checked all the PayPal settings and I'm seeing nothing in any Error Log.

I think my last PayPal payment was 25th March (most payments are Direct Debit or Stripe) so I didn't notice that this could have been an issue for a while.

 

~Scott

 

Share this post


Link to post
Share on other sites
Posted (edited)

@WHMCS Community, @WHMCS John I'm sorry to bother you but I've had some more of the same issues today.

I've got a PayPal case open but I wanted to come here first before I got direct to the support team.

Do you have any ideas on what I can try first?

 

Thanks

Scott

Edited by redit

Share this post


Link to post
Share on other sites

OK thats sods law.

Just got a reply from PayPal (24 hours later)

It turns out that you need to disable 'Encrypted website payments' in your PayPal account settings under Settings -> My Selling Preferences -> Website preferences

I don't know what happened, when this got turned on but after turning this off everything works again.

I would like to also point out that all of my site and services are encrypted with a valid SSL Certificate (I just double checked everything) and I don't remember turning this on so I'm guessing that its been on since day dot or has been added by PayPal as a security thing that I missed.

 

Share this post


Link to post
Share on other sites

Thanks Chris and All,

I sent an email to Paypal and they already responded. My problem is that fact that I'm Nigerian. Paypal does not allow some certain features to appear on their website if your system IP shows that you are in Nigeria.

The only option I have for now and which I have done is to disable Paypal from my payment gateway list and use other options that are working.

Thanks

Share this post


Link to post
Share on other sites
On 4/8/2019 at 10:48 AM, ebbydare said:

Thanks Chris and All,

I sent an email to Paypal and they already responded. My problem is that fact that I'm Nigerian. Paypal does not allow some certain features to appear on their website if your system IP shows that you are in Nigeria.

The only option I have for now and which I have done is to disable Paypal from my payment gateway list and use other options that are working.

Thanks

Have you tried the same solution of disabling encrypted payments as shown above? If not, please try that and see if it resolves your issue. Otherwise if you wish to use PayPal, it will be best to contact them to find out why they are displaying a generic error for payments to your account and get it corrected to resolve that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated