Jump to content
Superjedi

WHMCS system url change, site gets blocked out

Recommended Posts

I am running whmcs with php/apache/mysql in docker. I also use cloudflare for DDOS protection and letsencrypt from caddy.

Even though the site has been in https with ssl from cloudflare, the admin warning says my site isnt ssl protected.

The main  issue is after I change the WHMCS system url from http://example.com to https://example.com, the site gets blocked out.

I have checked every post related to this issue e.g. using curl -I https://example and the output is 200 so I cant see why the admin ssl says I am not using ssl.

these  dont help:

https://help.whmcs.com/m/troubleshooting/l/802231-troubleshooting-a-redirect-loop

https://help.whmcs.com/m/64969/l/680976-updating-the-system-url

https://whmcs.community/topic/268037-system-health-status-website-ssl-warning/

I have a feeling that if I dont get this fixed, I will encounter other ssl related issues later on e.g. other payment plugins refuse to work because whmcs thinks I am not using ssl even though the site is definitely ssl protected.

What is the whmcs system logic in determining my site isnt ssl? I have checked  using curl -I https://example.com and the result is 200 so warning logic isnt based on it.

Thanks in advance for any insight?

Vince

 

 

Share this post


Link to post
Share on other sites

Correct. The certificate is valid and it is provided by cloudlfare. 

In order to get back into the admin, I have to go  into MySQL and change whmcs system URL back to http://example.com.

That is if someone is kind enough to shed some light where whmcs is determining if my site has SSL protection ? There has to be a logic check.

 

Share this post


Link to post
Share on other sites

Hi @Superjedi,

16 hours ago, Superjedi said:

In order to get back into the admin, I have to go  into MySQL and change whmcs system URL back to http://example.com.

In Setup > General settings have you got both the Domain and WHMCS System URL set to use https?

Have you tried different setting for Friendly URLs?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated