Jump to content
Sign in to follow this  
PHPRush

Cron Job Returns an error

Recommended Posts

Hello,

 

Help me pls upto now no reply to my ticket more than 24hr over

Replacing vendor as well as the cron files doesnt worked!

 

Quote

<p class="debug">Error: Call to a member function createStorageProvider() on null in /home/XXXXX/public_html/controls/vendor/whmcs/whmcs-foundation/lib/File/Configuration/FileAssetSetting.php:0<br />
Stack trace:<br />
#0 /home/XXXXX/public_html/controls/vendor/whmcs/whmcs-foundation/lib/File/Storage.php(0): WHMCS\File\Configuration\FileAssetSetting->createFilesystemAdapter('')<br />
#1 /home/XXXXX/public_html/controls/vendor/whmcs/whmcs-foundation/lib/File/Storage.php(0): WHMCS\File\Storage->createAdapter('email_template_...')<br />
#2 /home/XXXXX/public_html/controls/vendor/illuminate/support/Facades/Facade.php(215): WHMCS\File\Storage->emailTemplateAttachments()<br />
#3 /home/XXXXX/public_html/controls/vendor/whmcs/whmcs-foundation/lib/Mail/Message.php(0): Illuminate\Support\Facades\Facade::__callStatic('emailTemplateAt...', Array)<br />
#4 /home/XXXXX/public_html/controls/vendor/whmcs/whmcs-foundation/lib/Mail/Emailer.php(0): WHMCS\Mail\Message::createFromTemplate(Object(WHMCS\Mail\Template))<br />
#5 /home/XXXXX/public_html/controls/includes/functions.php(0): WHMCS\Mail\Emailer::factoryByTemplate(Object(WHMCS\Mail\Template), 642, '')<br />
#6 /home/XXXXX/public_html/controls/vendor/whmcs/whmcs-foundation/lib/Cron/Task/InvoiceReminders.php(0): sendMessage('Invoice Payment...', 642)<br />
#7 /home/XXXXX/public_html/controls/vendor/whmcs/whmcs-foundation/lib/Cron/Task/InvoiceReminders.php(0): WHMCS\Cron\Task\InvoiceReminders->sendUnpaidInvoiceReminders()<br />
#8 /home/XXXXX/public_html/controls/vendor/whmcs/whmcs-foundation/lib/Scheduling/Task/AbstractTask.php(0): WHMCS\Cron\Task\InvoiceReminders->__invoke()<br />
#9 /home/XXXXX/public_html/controls/vendor/whmcs/whmcs-foundation/lib/Scheduling/Task/AbstractTask.php(0): WHMCS\Scheduling\Task\AbstractTask->execute()<br />
#10 /home/XXXXX/public_html/controls/vendor/whmcs/whmcs-foundation/lib/Cron/Console/Command/AbstractCronCommand.php(0): WHMCS\Scheduling\Task\AbstractTask->run()<br />
#11 /home/XXXXX/public_html/controls/vendor/whmcs/whmcs-foundation/lib/Cron/Console/Command/AbstractCronCommand.php(0): WHMCS\Cron\Console\Command\AbstractCronCommand->executeCollection(Object(WHMCS\Scheduling\Task\Collection))<br />
#12 /home/XXXXX/public_html/controls/vendor/symfony/console/Command/Command.php(259): WHMCS\Cron\Console\Command\AbstractCronCommand->execute(Object(WHMCS\Cron\Console\Input\CliInput), Object(Symfony\Component\Console\Output\ConsoleOutput))<br />
#13 /home/XXXXX/public_html/controls/vendor/symfony/console/Application.php(844): Symfony\Component\Console\Command\Command->run(Object(WHMCS\Cron\Console\Input\CliInput), Object(Symfony\Component\Console\Output\ConsoleOutput))<br />
#14 /home/XXXXX/public_html/controls/vendor/symfony/console/Application.php(192): Symfony\Component\Console\Application->doRunCommand(Object(WHMCS\Cron\Console\Command\AllCommand), Object(WHMCS\Cron\Console\Input\CliInput), Object(Symfony\Component\Console\Output\ConsoleOutput))<br />
#15 /home/XXXXX/public_html/controls/vendor/symfony/console/Application.php(123): Symfony\Component\Console\Application->doRun(Object(WHMCS\Cron\Console\Input\CliInput), Object(Symfony\Component\Console\Output\ConsoleOutput))<br />
#16 /home/XXXXX/public_html/controls/my-secured-folders/crons-pik0z/cron.php(0): Symfony\Component\Console\Application->run(Object(WHMCS\Cron\Console\Input\CliInput), Object(Symfony\Component\Console\Output\ConsoleOutput))<br />

 

Share this post


Link to post
Share on other sites

Hi there,

To follow up with a resolution in the event somebody else comes across this thread. This error indicates the saved Storage Settings values are no longer valid (possibly following a server move).

First test that your Storage Setting configuration are valid at Configuration > System Settings > Storage Settings > Configurations tab using the play icon

If not, please update them per this guide: https://docs.whmcs.com/Moving_Storage_Locations

If yes, then the values may just need re-saving. To do this:

  1. Select the Settings tab
  2. Toggle each of the storage settings dropdown menus to a different option, and then back to the original value
  3. Click Switch and confirm
  4. Repeat for each storage setting

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated