Jump to content
Remitur

Admin area access, 2FA and ERR_TOO_MANY_REDIRECTS

Recommended Posts

I have 2FA enabled on admin area access (Duo Security)
For existing administrators, everything is working fine.

But If I add a new administrator, the first time he tries to login (and that will be forced to configure 2FA), at  www.mydomain.com/admin/myaccount.php?2faenforce=1 I get the error message: 

This page isn’t working domainregister.international redirected you too many times.
Try clearing your cookies.
ERR_TOO_MANY_REDIRECTS 

(yet tried, of course, cookies clearing... it's useless, I get this error on different PCs too)

Any idea on any way to investigate such an issue?!? 😞

 

 

Share this post


Link to post
Share on other sites
1 minute ago, Remitur said:

Any idea on any way to investigate such an issue?!?

any chance that its being caused by .htaccess ?

https://help.whmcs.com/m/troubleshooting/l/802231-troubleshooting-a-redirect-loop

Quote

Redirect loops can be caused by .htaccess files which make use of an Apache mod called mod_rewrite. This is most commonly used for redirecting pages, creating human and search-engine-friendly URLs, and forcing pages to be loaded over a different protocol.

Share this post


Link to post
Share on other sites
1 hour ago, brian! said:

any chance that its being caused by .htaccess ?

 

Rewrite are enabled just:

- from http to https

-and from www. to not-www.

 

RewriteEngine On

RewriteCond %{HTTPS} on
RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ https://%1/$1 [R=301,L]

RewriteCond %{HTTPS_HOST} ^www\.(.*)$ [NC]
RewriteRule ^(.*)$ https://%1/$1 [R=301,L]

Everything seems right to me... are not able to understand what is not running right... 😕

Share this post


Link to post
Share on other sites

what happens if you disable Force Settings ?

you may be better off opening a ticket with support on this if you can't track down a fix.

  • Like 1

Share this post


Link to post
Share on other sites

Hummmm... I've just discovered that this configuration and management of redirects totally changed in 7.2 ... 😕

Need to do few tests... but deep in the night.

Share this post


Link to post
Share on other sites
4 minutes ago, Remitur said:

Hummmm... I've just discovered that this configuration and management of redirects totally changed in 7.2 ..

you mean Friendly URLs ? could turn into a very long night if you start trying to play with that!

Share this post


Link to post
Share on other sites

Fixed.
The issue: for security reasons, .htaccess was no writeable by WHMCS, so in it there were the old rules but not the new rules created by WHMCS 7.2

I guess that also a strange, different issue I fixed with a workaround few weeks ago may be related to this...

But during update process found any alert, warning or error about... 😕
All is well etc. etc.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated