Jump to content
stormy

TinyMCE formats everything when I copy/paste

Recommended Posts

I'm having trouble with TinyMCE on WHMCS 7.6.1 (I used to be on WHMCS 6.3.1 until recently). First, the gray text is kinda hard to read, any way to modify that?

And then, whenever I copy/paste text, formatting (color and background) is applied to it. i.e. if I copy/paste from the client area, white background is added to my paste. And if I copy/paste inside TinyMCE itself, grey type is applied to my copy/paste.

Share this post


Link to post
Share on other sites

That's why I hate WYSIWYG editors. They copy text including HTML and leave a lot of unnecessary and invisible tags. You have to options:

  1. Learn to use Edit HTML Source it's an icon in the editor
  2. Dont' paste text directly into TinyMCE. First paste it txt file then ctrl+c and ctrl+v in TinyMCE. This way you are not pasting HTML tags
  • Like 1

Share this post


Link to post
Share on other sites
16 hours ago, stormy said:

I'm having trouble with TinyMCE on WHMCS 7.6.1 (I used to be on WHMCS 6.3.1 until recently). First, the gray text is kinda hard to read, any way to modify that?

i'm not sure...

16 hours ago, stormy said:

And then, whenever I copy/paste text, formatting (color and background) is applied to it. i.e. if I copy/paste from the client area, white background is added to my paste. And if I copy/paste inside TinyMCE itself, grey type is applied to my copy/paste.

i'd go along with Kian's suggestions on this... when editing email templates, there is a third option to edit the email template in the database directly - bypassing anything that WHMCS might want to do to the code that you're adding... but as a rule, I tend to avoid using TinyMCE whenever possible.

  • Like 1

Share this post


Link to post
Share on other sites
16 hours ago, Kian said:

That's why I hate WYSIWYG editors. They copy text including HTML and leave a lot of unnecessary and invisible tags. You have to options:

  1. Learn to use Edit HTML Source it's an icon in the editor
  2. Dont' paste text directly into TinyMCE. First paste it txt file then ctrl+c and ctrl+v in TinyMCE. This way you are not pasting HTML tags

That's what I do. It's kinda tiring to be cutting/pasting stuff from a KB article just to reorder a paragraph and having to either lose all the formatting or opening the HTML view to strip the colors and background.

11 minutes ago, brian! said:

i'm not sure...

i'd go along with Kian's suggestions on this... when editing email templates, there is a third option to edit the email template in the database directly - bypassing anything that WHMCS might want to do to the code that you're adding... but as a rule, I tend to avoid using TinyMCE whenever possible.

Wow I didn't know this was such a contemptious issue. Ok, I'll have to skip it altogether then.

Share this post


Link to post
Share on other sites
18 hours ago, Kian said:

That's why I hate WYSIWYG editors. They copy text including HTML and leave a lot of unnecessary and invisible tags. You have to options:

  1. Learn to use Edit HTML Source it's an icon in the editor
  2. Dont' paste text directly into TinyMCE. First paste it txt file then ctrl+c and ctrl+v in TinyMCE. This way you are not pasting HTML tags

Most browsers have a shortcut for pasting as plain text. With CTRL-V being paste, also hold the SHIFT key, IE: CTRL-SHIFT-V. For me, anyway, that will ignore all pasted formatting in most programs/browsers, and I use it quite a lot. One notable exception is Opera. For some reason they use that shortcut to follow  a link, IIRC, but allows you to edit that in preferences. 

  • Thanks 1

Share this post


Link to post
Share on other sites
2 minutes ago, bear said:

Most browsers have a shortcut for pasting as plain text. With CTRL-V being paste, also hold the SHIFT key, IE: CTRL-SHIFT-V. For me, anyway, that will ignore all pasted formatting in most programs/browsers, and I use it quite a lot. One notable exception is Opera. For some reason they use that shortcut to follow  a link, IIRC, but allows you to edit that in preferences. 

Uuuuu! THANK YOU! 🤩 I didn 't know that!

Share this post


Link to post
Share on other sites
4 hours ago, WHMCS Sachin said:

Or you can just right click and select "Paste as plain text". Works for me in Chrome. 🙂

Yes, but I still lose the formatting. I.e: if I decide that I want to switch the order of a paragraph, or move a few sentences that already have bold and links, it's either lose the links and bolding or fix the extra formatting. And I still have to endure the small grey type. 😢

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines