Jump to content
perlancar

(7.6.1) empty ticket reply when staff enters non-ascii characters

Recommended Posts

When staff replies a ticket and the message contains non-ascii characters like ’ (U+2019 : RIGHT SINGLE QUOTATION MARK), the reply becomes empty. there is no empty message, the reply got posted, it's just that the message is empty. the message also doesn't get recorded in the database.

When client does this, at least the reply got rejected with the error message that she didn't enter any message (so yes, the message becomes empty again, but at least the user gets an error, she will be confused though).

Any solution to this? Should I submit a bug report?

The database tables tbltickets and tblticketreplies already have their default charset set to utf8.

Share this post


Link to post
Share on other sites

This issue might have something to do with the rich text editor. We also experience empty content when saving email templates and have to disable the rich text editor. Is there a setting to disable rich text editor when replying to tickets?

Share this post


Link to post
Share on other sites
7 hours ago, perlancar said:

When staff replies a ticket and the message contains non-ascii characters like ’ (U+2019 : RIGHT SINGLE QUOTATION MARK), the reply becomes empty. there is no empty message, the reply got posted, it's just that the message is empty. the message also doesn't get recorded in the database.

When client does this, at least the reply got rejected with the error message that she didn't enter any message (so yes, the message becomes empty again, but at least the user gets an error, she will be confused though).

Any solution to this?

quickly testing this on my v7.6.1 dev, i'm not seeing this issue - e.g as an admin, I can add ' (or any other non-ascii) character to replies without issue... it gets stored in the database and is included in the email replies.

7 hours ago, perlancar said:

Should I submit a bug report?

if you're using a WHMCS admin template, e.g Blend or v4, i'd start by opening a Support Ticket first and take it from there.. maybe there's a configuration issue with your setup, or a corrupt/incomplete installation, that they will be able to spot.

Share this post


Link to post
Share on other sites

Hi brian!

Thanks, I've submitted the support ticket. Yes, I've tested using the admin templates blend as well as v4, the problem happens on both.

Share this post


Link to post
Share on other sites

Update: the problem is solved, via support ticket to WHMCS. It's not a bug, but a configuration issue. Setup > General Settings > Localisation > System Charset needs to be set to utf-8, not e.g. iso-8559-1.

Share this post


Link to post
Share on other sites
11 hours ago, perlancar said:

Update: the problem is solved, via support ticket to WHMCS. It's not a bug, but a configuration issue. Setup > General Settings > Localisation > System Charset needs to be set to utf-8, not e.g. iso-8559-1.

i'm glad you got it sorted - though when you said that those database tables were already utf8, I had assumed (mistakenly) that your system charset setting was set to that too.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines