Jump to content
Hannan

WHMCS Cron email not getting it anymore? Since 2 days ago!

Recommended Posts

Hi,

Since 2 days ago we are not getting the WHMCS Cron emails. However, as I can see the results. Suspension/termination/charges. It still does it job but not getting the email. The only thing we have touched is Apache that may affect on this. The website was going down for no reason so we had to change few things on Apache.

Please advise?

Share this post


Link to post
Share on other sites

Utilities > Logs > Email Message Log

Is there any error?

Share this post


Link to post
Share on other sites
8 minutes ago, Kian said:

Utilities > Logs > Email Message Log

Is there any error?

No, nothing in Email logs. Just usual client emails!

Share this post


Link to post
Share on other sites

Hi @Hannan,

Please begin your troubleshooting by reviewing Utilities > Logs > Activity Log and ensure you see a number of entries beginning "Cron Job" and "Automated Task" each day. The final entry every day should be "Cron Job: Completed Daily Automation Tasks".

* If you see no Cron Job entries at-all this means you have not configured your automation cron correctly, you must do this per our installation instructions. The relevant documentation can be found at http://docs.whmcs.com/Crons

* If you see some Cron Job entries but none after "Automated Task: Starting Server Usage Stats" your cron is getting stuck at the Usage Stats Update stage. The most likely cause of this error is that you have an old server in Setup > Servers that is no longer available.
To resolve this, you should update or remove any inactive or offline servers from Setup > Servers so that they can all be connected to successfully. Or alternatively Update Usage Statistics can be disabled under Setup > Automation Settings.

* Finally, if you see some Cron Job entries but no "Cron Job: Completed Daily Automation Tasks" entry this suggests the cron is being terminated prematurely by your server. Please increase the memory_limit and max_execution_time settings in your server's php.ini to 64M or 128MB which should easily be sufficient. Then see if things improve and you start getting the cron job report again over the next few days.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines