Jump to content
GoogieHost

Invoices are not getting marked as paid

Recommended Posts

Hey Mate!

We are using 2 payment gateways as of now PayPal and Razor pay with their latest available module but I don't know if payment is paid it's not reflecting in our WHMCS portal. We also have correct IPN settings (our WHMCS path) for PayPal and correct RazorPay credentials. 

Share this post


Link to post
Share on other sites
2 hours ago, GoogieHost said:

We are using 2 payment gateways as of now PayPal and Razor pay with their latest available module but I don't know if payment is paid it's not reflecting in our WHMCS portal. We also have correct IPN settings (our WHMCS path) for PayPal and correct RazorPay credentials. 

I assume you are now using WHMCS v7.6 as your site has missing FontAwesome5 icons... if so, are you using the free RazorPay module mentioned in Marketplace because it's only listed as being compatible upto v7.1; even what I assume is the 'official' RazorPay module is a couple of years old, so there's no guarantees that would work with v7.6 either.

for the RazorPay issue, i'd recommend contacting it's developer and checking that it's v7.6 compatible.

Share this post


Link to post
Share on other sites
On 9/24/2018 at 7:51 PM, brian! said:

I assume you are now using WHMCS v7.6 as your site has missing FontAwesome5 icons... if so, are you using the free RazorPay module mentioned in Marketplace because it's only listed as being compatible upto v7.1; even what I assume is the 'official' RazorPay module is a couple of years old, so there's no guarantees that would work with v7.6 either.

for the RazorPay issue, i'd recommend contacting it's developer and checking that it's v7.6 compatible.

But its not working with PayPal as well 

Share this post


Link to post
Share on other sites
1 hour ago, GoogieHost said:

It should be working with PayPal at least, tried to fix with IPN and some other troubleshoots but didn't worked 

Have you checked the Gateway log in the Billing menu? Do you see any entries related to the invoices where are not being marked paid? It should give you some idea why the payments are not being applied to the invoices. 

Share this post


Link to post
Share on other sites
6 minutes ago, WHMCS Sachin said:

Have you checked the Gateway log in the Billing menu? Do you see any entries related to the invoices where are not being marked paid? It should give you some idea why the payments are not being applied to the invoices. 

It says 

IPN Handshake Invalid
 

Share this post


Link to post
Share on other sites

https://docs.whmcs.com/PayPal#IPN_Handshake_Invalid

Quote

Getting this message in your Gateway Log would mean that WHMCS is unable to verify that the callback occurring has come from PayPal. This is to stop any false payments being applied to your account, however, on occasion, some valid payments can generate this error. Follow the instructions above for setting the Charset of your IPN to stop this.

 

Share this post


Link to post
Share on other sites

We have the same issue since we have updated the 2CO module (from the hotfix section), randomly on some transactions the logs say "Invoice ID Not Found"

Thanx!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines