Jump to content

Recommended Posts

is there a setting for the time within WHMCS?  I can't find one.

My server time is BST (currently) and is showing the correct time.

WHMCS is showing GMT - so one hour behind.

Not noticed this before the upgrade to 7.6, so not sure if it was wrong then as well.

Any thoughts?

Share this post


Link to post
Share on other sites

Hi @isdoo

https://docs.whmcs.com/Changing_Timezone

The time under which your WHMCS installation will run is based upon the server clock and the timezone setting in your PHP configuration. Therefore to change the time displayed in WHMCS there are two options:

Change the server clock directly
Edit the PHP configuration specifying a different timezone.
Changing the server clock may not be desirable if clients are hosted on the server and would require root access, so option 2 is the most viable for the majority of users. A number of hosting providers allow the PHP configuration to be changed on an individual directory by creating a php.ini file within the WHMCS directory. In that situation the following line could be added:

Quote

date.timezone=Europe/London

For a full list of the available timezone localities you can use, please refer to http://www.php.net/manual/en/timezones.php

Please contact your hosting provider/server admin if you are unsure how to customise the PHP configuration of your server.

Share this post


Link to post
Share on other sites

Thanks. However my server time is correct. I connected via a terminal and ran the date command to double check. 

It is WHMCS that is one hour behind. 

Odd. 

Share this post


Link to post
Share on other sites

you can set a timezone  in the configuration.php file too... that will only affect WHMCS.

 

  • Like 1

Share this post


Link to post
Share on other sites

Can't find any time setting locally. 

Configuration.php doesn't have a setting
no local php.ini file

If I use terminal into the server and run date it is correct
if I use terminal directly into the account it is correct

date
Fri Sep 28 12:45:34 BST 2018

However WHMCS is running on GMT and not BST so everything is run an hour late.

It is not showing the server time or the account time - both of which are the same.

It has to be WHMCS - I think!

Share this post


Link to post
Share on other sites
2 hours ago, isdoo said:

It is not showing the server time or the account time - both of which are the same.
It has to be WHMCS - I think!

this sounds pretty normal to me - and it's why i've got that line above added to my configuration file.

in any event, the clocks go back in four weeks time, so BST won't then exist for 5 months after that!

Share this post


Link to post
Share on other sites
On ‎9‎/‎16‎/‎2018 at 3:15 AM, brian! said:

you can set a timezone  in the configuration.php file too... that will only affect WHMCS.

 

This worked, Thank you!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines