Jump to content
Isaac Asher

Unable to send email through WHMCS

Recommended Posts

I had sent a few emails to a few clients through the client section in the admin area, and all worked as expected.  Tonight when I went to send a new email to a client, I get a 500 server error page and no entries are made in the email history to the client. 

Utilities > System > Activity Log does not show any error messages.  The last message printed in the log was where I turned on the debug logger. 

Any ideas? 

Share this post


Link to post
Share on other sites

Hi @Isaac Asher,

A 500 Internal Server Error is a generic error message produced by the server due to a misconfiguration. There are potentially a wider number of causes for such a problem, here is a brief overview of them and potential fixes:

* File Permissions are incorrectly set.  Should be (depending on server but general rule of thumb) 644 for files and 755 for folders/directories.
* An error in one of the PHP Files - Try enabling the display errors options described at http://docs.whmcs.com/Blank_Pages
* PHP Memory & Process limitations - Try increasing to 128MB
* PHP Process Limitations - Check with server admin/hosting provider
* Corrupt PHP Modules, Extensions, Builds - Check with server admin/hosting provider
* The obscure - If points 1-5 don't produce a fix typically the best course of action is to check the Apache Error Logs

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines