Jump to content
battles

An automatic renewal attempt was triggered for this service but failed. The renewal will not be attempted again automatically. Please resolve the error and try again.

Recommended Posts

I am now also getting TONS of these alerts after update

An automatic renewal attempt was triggered for this service but failed. The renewal will not be attempted again automatically. Please resolve the error and try again.

Client ID: 85
Service ID: 3681
Product/Service: xxxxxxxxxxxxxx
Domain: xxxxxxxx
Error: Module Not Found

These are mostly occurring on 1 or 2  products that we have. There is NO module associated with this product. What is going on?

 

I notice now on all these products that I get a spinning wheel when you go the Module settings tab of the product. Spins and spins

 

modset.PNG

Share this post


Link to post
Share on other sites
Hi Battles,
 
May be renew function is missing in your module that's why you are getting this error.
 
For spinning issue, Please make sure have you assigned the module with that product. If yes, then enable the debug mode with your WHMCS.
 
Follow these steps: 
 
Setup > General Settings > Others tab, enable  Display Errors, SQL Errors, etc and then open the browser developer debugger tool. Select that assigned module and see the error.
 
Right click > Inspect Element > Network tab.
 
Thanks
Thanks

Share this post


Link to post
Share on other sites

Whats strange is these have never had any associated modules. They are manually created products that are simply used for price and description.

Share this post


Link to post
Share on other sites

I have the same problem. On ours it looks like it's for products that have no module associated with them. Like OP, we don't use a module with these products. Hopefully a fix will be released soon--don't need to get a ton of these every time renewals happen.

Share this post


Link to post
Share on other sites

I am experiencing this same issue.  8-1 was the renewal date for all our remaining DSL/Dialup customers (yes, they still exist) and of course, there is no module for that... it has to be hand controlled.  So there has never been an associated module, it's set to NONE.

But at midnight, when it billed the customers (and did so successfully), it sent me 100's of emails stating the "Error:  Module Not Found", just like you mentioned above.  And I was going to start a threat about it when I found this post.

Any Ideas?

Share this post


Link to post
Share on other sites

Good morning,

We have the same problem after upgrading to 7.6.0, multiple emails per day. We have lots of products and orders on WHMCS and it would take too much time to go and change all these due to the update.

Is there a way to turn off these notifications?

Thanks,

Share this post


Link to post
Share on other sites

Marcus' suggestion is the answer... I changed the Module from "NONE" to "AUTO RELEASE" and the emails stopped.  While Auto Release does give you a bunch of options to email you for different reasons, you can just leave them off and not get any emails.

But, you WILL want to change all products to "Auto Release" if it isn't associated with any other module.  None shouldn't be used.

 

Share this post


Link to post
Share on other sites

If the "Auto Release" module is the recommended option, why even have "None" as an option?  IMO, "None" should should do what it says...  Bypass all automation tasks upon item renewal.

Share this post


Link to post
Share on other sites
3 hours ago, bcurtis said:

If the "Auto Release" module is the recommended option, why even have "None" as an option? 

I suspect because the dropdown uses an onchange and so changing the dropdown value triggers the selected module configuration settings to be shown.

Share this post


Link to post
Share on other sites
1 minute ago, brian! said:

I suspect because the dropdown uses an onchange and so changing the dropdown value triggers the selected module configuration settings to be shown.

Valid point, but this option could have just as easily been labeled "Select one" or something other than "None" to avoid confusion.  Logic could have also been used to either warn or error out when the "None" option is selected, if it wasn't intended to be used as a valid option.

I guess it's just my OCD combined with confusion as to why we can't have a billable item without an automation task attached.  Fortunately we only had a handful of items that required changes.

*shrug*

Share this post


Link to post
Share on other sites
18 hours ago, bcurtis said:

Valid point, but this option could have just as easily been labelled "Select one" or something other than "None" to avoid confusion.  Logic could have also been used to either warn or error out when the "None" option is selected, if it wasn't intended to be used as a valid option.

it probably never crossed their mind to change it as it's always been "none" (or language equivalent) from back when none was an acceptable answer... though it's not a crazy suggestion you make.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated