Jump to content
Sign in to follow this  
Ambarella

Email Verification Not working

Recommended Posts

Hello,

My WHMCS is having a issue with verifying client email addresses, it seems the email verification notice is not getting reach to anyone, i even tried with my own account and im not getting the email verification also. What could be the problem and how to sort it out ?

Dev 

Share this post


Link to post
Share on other sites
3 hours ago, Ambarella said:

My WHMCS is having a issue with verifying client email addresses, it seems the email verification notice is not getting reach to anyone, i even tried with my own account and im not getting the email verification also. What could be the problem and how to sort it out ?

https://docs.whmcs.com/Client_Email_Verification

obvious first thing to double- check is that the feature is enabled in setup -> general settings -> security..

then check if the template is disabled in setup -> email templates.

and then check the activity log to see if it says the email was sent.

 

Share this post


Link to post
Share on other sites

Also, check if go to spam/Junk folder I see that happened now a lot of time :) 

Share this post


Link to post
Share on other sites

there;s nothing worth with security settings and emails template is enabled too. However pls see the attached for the activity log, it seems non of the emails are going through :/

 

Share this post


Link to post
Share on other sites

are you using "default" as your main template, and "verticalsteps" for the orderform ? because if you are using "default" with v7.5, that's going to be the main cause of your problem.

that client area template got removed when v6 got launched in July 2015...

https://docs.whmcs.com/Version_6.0_Release_Notes

Quote

Version 6.0 introduces a new client area template theme named six. This will be the default theme for all new installations.

Upgrading will not change the theme your WHMCS installation is configured to use and all previous templates compatible with WHMCS 5.x versions can still be used in Version 6.0.

We will continue to support and maintain today's current default client area template theme in V5.x under the template name five. However, please be aware that new features and functionality may not be fully supported by default in the "five" theme either now, or in the future. For the avoidance of doubt, new functionality may only be implemented to the "six" theme and not backported to "five".

With the release of WHMCS 6.0, we are also deprecating our two oldest client area template themes - classic and portal. As of this release these client area template themes will no longer ship with WHMCS and will receive no further updates. They will continue to remain in the 5.3.x releases until such time as 5.3 reaches End of Life.

We strongly recommend that all new custom themes and templates are built based off the latest current client area template theme six in order to take full advantage of the latest improvements and new functionality.

so "Default" was renamed to "five"... and then "five" got removed when v7 was launched in 2017... and "verticalsteps" was removed in v6.1 at the end of 2015.

if you've been upgrading from previous versions since v5, you'll still have all these templates/orderforms in your installation, but most of them will be incompatible (or at least not 100% compatible) with WHMCS v.7.5 and certainly won't be able to use the newer features such as Email Verification... and certain aspects of MarketConnect too (which would also explain the smarty template errors visible in your above activity log).

if you want to use these newer features, the solution is going to be switching to "Six" and "Standard_cart" (or one of it's child themes) - once you do that, then the email verification, and other newer features (e.g those added since 2016!) should work. :idea:

Share this post


Link to post
Share on other sites

Ok to be frank im having lot of other issues with my WHMCS also, 

1. Client Email verification not working
2. WHMCS contact form not working 
3. Recurring orders wont auto update on the system and as a result clients always complain and i have to manually update all recurring orders .
4. Im not getting any notifications to my email what so ever.
5. Unable to attach files in the help desk from both client and admin end 

6. When a new client signs up using the registration form , and the plc where you have to put your password, it has a password strength indicator but doesn't really say anything abt password requirements, such as (minimum 15 characters, with a mix of lower case, upper case, numeric and special characters  etc) So even if you come with a complex password with less than 15 characters , the strength indicator goes over 80% and when u submit the form it keep on saying password strength is not enough but doesn't really say that the characters should be 15 :/ 

Basically it's all a mess. And so what your saying is this is all because of the Customized theme im using on my WHMCS ? or is it the order form "Vertical Steps" ?

What is the default template for order forms ? which auto updates with the main software when its updated ?

Pls see the attached error msg for the contact form, it never goes through 

 

whmcs-contact-form-error.jpg

Share this post


Link to post
Share on other sites
1 hour ago, brian! said:

are you using "default" as your main template, and "verticalsteps" for the orderform ?

Im not using the default as the main template "I think" :D and yes im using vertical steps for the order forms.

Share this post


Link to post
Share on other sites

This is the main template, i have no idea whether its the default or not, all i remember is that i was editing the colors of the buttons and top header section.

 

 

Portal Home.jpg

Edited by Ambarella

Share this post


Link to post
Share on other sites
3 hours ago, Ambarella said:

And so what your saying is this is all because of the Customized theme im using on my WHMCS ? or is it the order form "Vertical Steps" ?

almost certainly - at the very least, it's not helping.... Vertical Steps would be a problem in the cart as it hasn't been updated in years, so WHMCS will be doing things in the background that the template simply won't be expecting to handle... and vice versa.

3 hours ago, Ambarella said:

Pls see the attached error msg for the contact form, it never goes through 

I can see the contact.php error, and it exists when using the Six theme on your site too... which implies it's a settings issue (you probably have many settings that worked in earlier versions, but may not work now)... perhaps the thread below will help that issue.

6. (the password strength issue) might be caused by your template using it's own js strength-checking code and it being incompatible with v7.5.

3 hours ago, Ambarella said:

What is the default template for order forms ?

if you had a clean installation, the default main template is "Six" and the default orderform template would be "Standard Cart"... your opening cart page would look like..

3kZe1xm.png

3 hours ago, Ambarella said:

which auto updates with the main software when its updated ?

Six and Standard_Cart definitely will, and then there might be occasional minor changes to the five Standard_cart children orderform themes (Pure/Premium/Supreme Comparison and Cloud/Universal Slider)... there may be very minor tweaks to "Modern" and "Boxes", but basically they're both deprecated too... and then any orderform templates that I haven't specifically listed previously have definitely been deprecated and will never be updated again.

3 hours ago, Ambarella said:

This is the main template, i have no idea whether its the default or not, all i remember is that i was editing the colors of the buttons and top header section.

it's definitely "Default" - just looking at it, it looks like default or five, and checking the source code in the browser, confirms that it's default.

dwPIfBS.png

in an ideal world, what you would do next is go to setup -> general settings -> general and change your template in the dropdown from "Default" to "Six", and then change your orderform template too... however, I assume that this is a live production site and you don't want to be messing with it and potentially losing sales (though if parts of it aren't working, then that might be immaterial)...

if you want to quickly test a page using another template, e.g six, or an orderform template, e.g standard_cart, then you can modify the url and only you will see the site like that - existing customers will still see the default / verticalsteps themes.

so, let's imagine that your WHMCS cart is at https://www.my.ambarella.com/cart.php (change amberalla to your real domain)... to see them using different templates, you can use...

Six ->  https://www.my.ambarella.com/cart.php?systpl=six
Standard Cart -> https://www.my.ambarella.com/cart.php?carttpl=standard_cart
Six & Standard Cart -> https://www.my.ambarella.com/cart.php?systpl=six&carttpl=standard_cart

you will then continue to see the site using those templates until you either close the browser and/or clear the cache... doing this will allow you to modify the Six/SC themes in the background until you are completely happy to switch to them.

it might also be worth you having a play with a Softaculous WHMCS Demo as that will give you a demonstration of what a clean installation of v7.5.1 looks like from both the admin and client sides... it won't have any products/domains in it (you can add them temporarily if you want to though), but all other features should be the same as your installation. :idea:

Share this post


Link to post
Share on other sites

HI Brain Thanks so much for the in depth clarifications on my WHMCS related issues.  So by switching into SIX template and standard cart, will it resolve all the issues im having with my WHMCS? Im currently in the process of changing the main template and order forms to Template SIX and Standard cart, took a full backup if something goes wrong.  And also,... can you pls guide me with editing the colors of the six template to match my site. I need to change the colors of the areas which i have  marked in red dots. 

Thanks again for your support

Template-six.jpg

Share this post


Link to post
Share on other sites
2 hours ago, Ambarella said:

So by switching into SIX template and standard cart, will it resolve all the issues im having with my WHMCS?

no-one could guarantee that, but it should at least resolve some of them...

3 hours ago, Ambarella said:

can you pls guide me with editing the colors of the six template to match my site. I need to change the colors of the areas which i have  marked in red dots. 

the usual way to do this would be to use /templates/six (or custom)/css/custom.css and add...

ul.top-nav > li.primary-action > a.btn {
    padding: 6px 15px;
    background-color: #0e5077;
    color: #fff;
    border-radius: 3px;
}

.navbar-main {
    margin-bottom: 0;
    background-color: #0e5077;
    border: 0;
    min-height: 38px;
    font-family: "Raleway", "Helvetica Neue", Helvetica, Arial, sans-serif;
    font-size: 15px;
}

section#home-banner .btn.search {
    background-color: #4ab98b;
}
section#home-banner .btn.transfer {
    background-color: #bbb;
}

section#home-banner {
    margin: 0;
    padding: 50px 0 60px;
    background-color: #043d5f;
    color: #fff;
}

.home-shortcuts {
  margin: 0;
  background: #25a2c7;
  color: #fff;
}

going from top to bottom of your image, these are the css classes for those six red dots.... you should just need to change the #colors in each to suit your old theme (you could remove the other options if you aren't changing them)... there may need to be a couple more, e.g shortcuts have borders, but you can find them in templates/six/css/all.css - just copy the ones you need to change to custom.css and you should be good to go.

Share this post


Link to post
Share on other sites

Ok i have update the main template to the SIX and also the order forms to standard cart, and only the main template has updated successfully and not the order form, im still getting the vertical steps. Cleared the cookies and cashe also, and checked from a mobile device but still pointing to the vertical steps order form. :/

And i went through the thread you gave regarding the contact form issue, and it does't solve the exact problem, but what it does is when you do the changes from Setup > general settings > Mail > "Presales Form Destination" it basically convert the basic contact form to a support ticket submission form which is for the registered clients only. And the form submitted through that form is also went missing and no where to be found. :/ and for the non registered clients the basic contact form should be there. What exactly is wrong ? Im still not getting the email notification when a new ticket / reply comes in and still unable to attach files when submitting tickets.  

Edited by Ambarella

Share this post


Link to post
Share on other sites
2 hours ago, Ambarella said:

im still getting the vertical steps. Cleared the cookies and cashe also, and checked from a mobile device but still pointing to the vertical steps order form.

perhaps each of those first four product groups has a custom orderform template assigned to them - that could override the setting in general settings... "Dedicated Servers" seems to be using standard_cart... take a look in setup -> product/services -> product/services, click on any of the first four product groups and change it to use System Default orderform template

Ts3MJ12.png

2 hours ago, Ambarella said:

What exactly is wrong ?

ok, you're hitting two problems here...

2 hours ago, Ambarella said:

what it does is when you do the changes from Setup > general settings > Mail > "Presales Form Destination" it basically convert the basic contact form to a support ticket submission form which is for the registered clients only.

this is because you've assigned presales enquiries to a support department that is for clients only... there's nothing to stop you from creating another support department specifically for general enquiries, but leaving the "Clients Only" checkbox unticked...

P59zjFS.png

... if you do that, anyone will be able to contact you and it should open a support ticket.

2 hours ago, Ambarella said:

And the form submitted through that form is also went missing and no where to be found.

as @WHMCS ChrisD says at the end of the above thread, perhaps there is a PHPMailer or general mailing issue with your server.... that might be something to discuss with your hosting company about, or WHMCS support.

3 hours ago, Ambarella said:

for the non registered clients the basic contact form should be there.

well you can either link presales to a support department (which can't be set to client-only); or you link it to the contact form, which should send the results in an email to the entered email address - if it doesn't, or the form has an error (which it does), then as Chris says, there may be a PHP error.

also, because you've been constantly upgrading WHMCS (from v5 I assume), you're still going to have a lot of old files lurking around on the server that may be causing issues...

Share this post


Link to post
Share on other sites

Most issues with e-mails are due to not using SMTP as the Mail Type under Setup > General Settings > Mail tab and correcting that usually resolves them: https://docs.whmcs.com/Mail_Tab#Mail_Type

If you are unsure of the settings to use for your SMTP, please contact your provider and they can assist you with that.

Share this post


Link to post
Share on other sites
9 hours ago, Shobha Patwal said:

Earlier link is showing but now no link is generating using the variable {$client_email_verification_link}

Are you facing the same issue?

Please send more information.

Share this post


Link to post
Share on other sites

Please ensure that you are using the "Resend Verification Email" option shown on the Client Summary page itself. If the merge field isn't being replaced with the unique, this usually suggests that the e-mail is being sent manually using the unrelated "Send Email" option and won't work as expected.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By isixhosting
      Hi,
      by mistake I have deleted the Email Verification Template from the database and now the "Send/Resend Verification Email" doesn't work.
      I have looked in the 'emailtemplates.sql' in the installation folder, but there isn't such template/table called 'Email Verification Template'...
      How can I get it working/restore again?
      P.S. The send/resend buttons are there, in the admin as in the client area as well, but they do nothing and the 'Activity Log' is empty nor any error warnings/messages on the site or logs.
      Thanks
    • By wsa
      We just finished updating the Email Verification Extended to v6.0.1 to work on WHMCS v7.3 and PHP 7
      Find out more about Email Verification Extended from WHMCS
      Screenshot: Click Here
      Sale Price:
      Owned License: $20.99 USD Click Here
      Click Here To View All WHMCS Addons By WHMCSServices
      Do You Need Custom Development? Click Here
      Latest Release:
      SMS Manager 5.1.0
      Gateway Fees 3.2.1
      Uptime Status 1.3.0
      Enom Security 2.0.0
      Client Deletion Modules 1.0.2

      Coming Soon:
      Ticket Number Restriction 2.0.0
      PayPal Extended 4.0.0
      Backup Module 1.0.0
       
    • By rabijit
      is there any way to force email verification on whole client area .
       
      i can do this
       
      {if $emailVerificationPending}
       
      <p> Verify your email to continue</p>
      {else}
       
      ======
       
      {/if}
       
      via template level but want to implement in everywhere
       

    • By Trax
      Hi,
       
      I am using a custom template for whmcs and i notice that with the client area the "Email Validation" field is not showing. (yes it's enabled )
       

       
      Can anyone tell me the code and the template to edit so this will be displayed to clients?
       
      Thanks!
    • By Nuk3na
      Hi Guys,
       
      Ive searched and tried some troubleshooting guides within the forums but I can not seem to get my email verification to work properly.
       
      Say I have a customers that registers after paying for a package - They get the verification email however when they click the link it takes them to the client area login - they login and it still does not verify them - also when they are logged in they can click the link again and it still does not verify there email address?
       
      Does anyone know what the issue maybe?
       
      If this has been addressed and I have missed the answer some where in the forums I apologize in advance.
       
      Kind Regards
       
      Nuk3na
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated