Jump to content
cluster

Transactions Related Client search does not work

Recommended Posts

I'm unable to enter a new transaction, the search function of the Related Client textfield does not work. I can enter anything, but no client is found.

> start typing to search clients

How can the problem be solved?

WHMCS 7.4.2

PHP 7.0x

Browser Chrome

 

Edited by cluster

Share this post


Link to post
Share on other sites

using which admin template - v4, Blend or a custom?

if memory serves, that dropdown will use selectize.js, so it's possibly a js conflict somewhere - but i'm not seeing it in my v7.4.2 or the online demo (using Firefox and Chrome).

xepcsS8.png

Share this post


Link to post
Share on other sites
3 minutes ago, cluster said:

hmm, this should be the default admin template, where can I change that?

click the "My Account" link at the top of the admin homepage and that should take you to the page (myaccount.php) to change templates.

Share this post


Link to post
Share on other sites

Thanks Brian, I tried w/ both but nothing changed

no other templates installed ...

 

    <link href="//fonts.googleapis.com/css?family=Open+Sans:300,400,600" rel="stylesheet">
    <link href="templates/blend/css/all.min.css?v=bd3b83" rel="stylesheet" />
    <script type="text/javascript" src="templates/blend/js/scripts.min.js?v=bd3b83"></script>
...

    <script>function getClientSearchPostUrl() { return '/clients/admin/search/client'; }</script>
<script type="text/javascript" src="../assets/js/AdminClientDropdown.js"></script>

 

Edited by cluster

Share this post


Link to post
Share on other sites

I wonder if it's linked to the Friendly URL settings - have you changed them recently...

your question was niggling me as it reminded me of a similar question - I think it was the above thread..

Share this post


Link to post
Share on other sites

strange ... so far, nothing has been changed w/ the URL settings ...

maybe the PHP version?

I use PHP 7.0.x

Share this post


Link to post
Share on other sites
Header always append X-Frame-Options SAMEORIGIN
Header set X-XSS-Protection "1; mode=block"
Header edit Set-Cookie ^(.*)$ $1;HttpOnly;Secure

or maybe this apache settings?

Share this post


Link to post
Share on other sites

i'm running the same PHP version on the dev... online demo is using PHP5.6 - dread to suggest that it might be worth opening a ticket with Support.

Share this post


Link to post
Share on other sites

the whmcs rewrite part was missing in the .htaccess, after adding this part it works ...

but now my phone number issue is back, if I submit a  domain registration via registrar module it cuts of the country code numbers, in database it shows the complete phone number but it does not work for the API anymore ... f.ex.

+33 9999999 is now formated as +9999999 also the country code number is now missing in the order emails

'phonenumber'         => preg_replace('/\./', ' ', "+".$params["phonenumber"]),

2 days ago before I have added the htaccess code it worked well,  RewriteBase is disabled because whmcs is running in it's own subfolder, it makes no change if disabled or not.

# RewriteBase is set to "/" so rules do not need updating if the
# installation directory is relocated.  It is imperative that
# there is also a RewriteCond rule later that can effectively get
# the actual value by comparison against the request URI.
# 
# If there are _any_ other RewriteBase directives in this file,
# the last entry will take precedence!
#RewriteBase /

# Redirect directories to an address with slash
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^(.+[^/])$  $1/ [R]

# Send all remaining (routable paths) through index.php
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
# Determine and use the actual base
RewriteCond $0#%{REQUEST_URI} ([^#]*)#(.*)\1$
RewriteRule ^.*$ %2index.php [QSA,L]
</IfModule>
### END - WHMCS managed rules - DO NOT EDIT BETWEEN WHMCS MARKERS ###

 

Edited by cluster

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines