Jump to content
Sign in to follow this  
HaNi Ghaith

Oops! Something went wrong and we couldn't process your request.

Recommended Posts

Hello,
You have upgraded from version 6.2.1 to version 7.4.1 recently.
I have gone through many problems but now I have a problem with the system.
The first problem relates to the upgrade of the template code and I have applied for an upgrade to the template's production.
But also I'm facing some other kaleidoscope and these are problem messages.

Oops!
Something went wrong and we couldn't process your request.
Please go back to the previous page and try again.

Whoops\Exception\ErrorException: The file /home/user/public_html/modules/addons/zomex_template_manager/hooks.php was encoded by the ionCube Encoder for PHP 4.0 and cannot run under PHP 7.0.
Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 5.6. in Unknown:0
Stack trace:
#0 /home/user/public_html/vendor/whmcs/whmcs-foundation/lib/Utility/Error/Run.php(0): WHMCS\Utility\Error\Run->handleError(16, 'The file /home/...', 'Unknown', 0)

1 [internal function]: WHMCS\Utility\Error\Run->handleShutdown()

2 {main}

I found this post:

Obviously she talks about the same problem

The employee is asked to consider that the file was in the next track that was present or not
/opt/cpanel/ea-php70/root/usr/lib64/php/modules/oath.so
I did not find him already
I searched for a way to install oath to php 7 but i cant find it.

Does anyone have an idea?

Best Regards

Share this post


Link to post
Share on other sites

Hello @HaNi Ghaith 

Thanks for your post. To start, remove the file /home/user/public_html/modules/addons/zomex_template_manager/hooks.php this only works on PHP 4 if you need it to work on PHP 5.6 or PHP 7 please contact @zomex for a updated version

7 hours ago, HaNi Ghaith said:

Whoops\Exception\ErrorException: The file /home/user/public_html/modules/addons/zomex_template_manager/hooks.php was encoded by the ionCube Encoder for PHP 4.0 and cannot run under PHP 7.0. Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 5.6. in Unknown:0 Stack trace:

 

In regards to your OATH issue please provide the error you are gettign for this

 

Share this post


Link to post
Share on other sites

Hello Hani,

Just noticed this thread but I know we solved this issue over ticket. You were using a version of the template from 2015 which was the cause of the error. This has since been updated.

Thanks,

Jack

Share this post


Link to post
Share on other sites

Hello,
First, let me thank you.
The Zomex employee has already fixed the bugs and now the site is working fine.
But this message remains:
Oops!
Something went wrong and we could not process your request.
Please go back to the previous page and try again.

And nothing else other than that message when you click on the Edit Product icon.

Can the cause be determined?
thank you.

Share this post


Link to post
Share on other sites

Hello
Thank you. The errors have already come up and are as follows:

 

Oops!

Something went wrong and we couldn't process your request.

Please go back to the previous page and try again.

Whoops\Exception\ErrorException: The file /home/user/public_html/modules/servers/enkompass/enkompass.php was encoded by the ionCube Encoder for PHP 5.3 and cannot run under PHP 7.0.
Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 5.6. in Unknown:0
Stack trace:
#0 /home/user/public_html/vendor/whmcs/whmcs-foundation/lib/Utility/Error/Run.php(0): WHMCS\Utility\Error\Run->handleError(16, 'The file /home/...', 'Unknown', 0)
#1 [internal function]: WHMCS\Utility\Error\Run->handleShutdown()
#2 {main}

Regards.

Share this post


Link to post
Share on other sites

Hello 

enkompass.php has been retired and you can go ahead and delete this file from you /modules/servers/ folder

Share this post


Link to post
Share on other sites

Hello,
That's what I really do.
But it turned out that there were so many files I had to change the name of the folder modules to another name and upload the entire folder from version 7.4.1.
I noticed there were many problems here and there but after changing the entire folder all ended.
Now uploads the required modules after uploading their latest update.

Best Regards.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated