Jump to content
Sign in to follow this  

pipe email for support all works as expected, but client gets a weird bounce email back

Recommended Posts



So I have WHMCS installed under my domain which is on a VPS server running Cloudlinux. This supports multiPHP so I can have different domains running various PHP versions.


For this domain and WHMCS I have PHP 7.0 and ionCube Loader 5.6 (which works for PHP 7.0).


Because of the way Cloudlinux is configured for multiPHP I had some fun and games initially setting up WHMCS and getting cron configured, until I realised that it was by default pointing to the default PHP location, and not PHP 7.0 with ionCube Loader built into it. Changing the path to explicitly use the correct PHP build fixed it.


That served me well setting up the forwarders to pipe emails to the support area. Once I set them up also pointing to the right PHP build everything worked fine. An example of the forwarder pipe is:


/opt/cpanel/ea-php70/root/usr/bin/php -q /home/yourscope/whmcsdata/crons/pipe.php


After set up, anyone raising an email to a support email address gets a notification of their ticket being opened. I as the admin get an email notification a ticket has been raised, and the ticket is nicely there in the support area of WHMCS. Happy days. The trouble is, the customer sending that original email, as well as getting the correct notifications, also gets this weird bounced email that says:


This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

 pipe to |/opt/cpanel/ea-php70/root/usr/bin/php -q /home/yourscope/whmcsdata/crons/pipe.php
   generated by [email]info@yourscope.co.uk[/email]

The following text was generated during the delivery attempt:

------ pipe to |/opt/cpanel/ea-php70/root/usr/bin/php -q /home/yourscope/whmcsdata/crons/pipe.php
      generated by [email]info@yourscope.co.uk[/email] ------

Failed loading /usr/local/IonCube/ioncube_loader_lin_5.6.so:  /usr/local/IonCube/ioncube_loader_lin_5.6.so: undefined symbol: zval_update_constant_inline_change

Action: failed
Final-Recipient: rfc822;|/opt/cpanel/ea-php70/root/usr/bin/php -q /home/yourscope/whmcsdata/crons/pipe.php
Status: 5.0.0


Now, I've looked everywhere for hours (including WHMCS docs) and did find a number of similar issues that have solutions around pipe.php permissions, or redirecting its output to NULL and a bunch of other things. None of these have worked nor reference loading ionCube being part of the problem, or the fact I have multiPHP environment.


Given all is actually good, I simply wanna stop that bounce and the path of the ionCube loader is correct. Anyone have any ideas please as to why it's complaining, and what I can do to either fix it or suppress it?


Many thanks.

Share this post

Link to post
Share on other sites

Ok I fixed this.


In case anyone else has a similar problem...


It is all to do with the local.ini file if you use MultiPHP. When I looked at the one for PHP7, the local.ini file was pointing to the wrong ionCube loader for PHP 7.0. Hence it spitting out a PHP error.


Changing the local.ini file by commenting out the ref to the wrong ionCube loader (via the "MultiPHP INI Editor" sidebar option in WHM for PHP 7.0) solved this:




MultiPHP had a one line ini for the correct loader, but I think the order in which these piecemeal ini files are loaded / read meant that the 5.6 loader line was the last one read, overriding the correct loader line.


Anyway - all is at one in the world once more.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By startover909
      I'm currently in the process of setting up WHMCS (7.5.1) along with a main site on a pretty much empty dedicated server (decent E3 with SSD). The site does not run "slow" by any means. It loads in about 650ms to 800ms on Pingdom and GTMetrix tests. What I did find curious is that it is exactly and consistently around 200ms slower TTFB compared to the same sites on the same server, mostly running Wordpress. All running the same PHP and MySQL and over SSL (so all the overheads are accounted for). So while the other site would have a TTFB of say 250ms to a given test server (including SSL handshake), WHMCS would take about 450ms, pushing it just a bit over the most "ideal" ballpark. This can be also easily verified by using Chrome's developer tool - network tool.
      Is this 200ms due to the IonCube encoding, or is the speed of the application itself just what it is? Does this number seem right to you? If you have any other PHP/MySQL site especially Wordpress running along side WHMCS on the exact same server, and not utilizing CDN's such as cloudflare that can skew the results,  do you mind doing a test and see if your WHMCS is also consistently a bit slower TTFB (test during idle times)?
    • By John Kennedy
      Getting error 500 when trying to access todo lists. Seems to be happening after the update to 7.5.1.
      ./admin/todolist.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later." Host:
      nginx + FPM
      php 7.1.16 + ionCube Loader 10.1.0

      The original installation 7.2.x was running on php5.6.35 + iCL6.0.7, and I think this is where the issue is coming from. Is it possible ./admin/todolist.php wasn't updated with 7.5.1?
    • By WHMCS John
      After applying the 7.5 update, you may encounter the following error:
      The file /path/to/whmcs/index.php is corrupted. Where /path/to/whmcs/ is the location of your WHMCS installation.
      This message occurs when the server environment does not have a sufficiently recent version of the Ioncube Loaders installed so as to meet the compatibility requirements.
      This error will occur if you are running Ioncube Loaders version 10.0 or earlier. WHMCS 7.5 requires Ioncube Loaders 10.1.0 or above.
      Update the IonCube Loaders installed on your server to version 10.1.0 or higher in PHP 5.6 or 7.0, then attempt the update process again.
      Once the update to WHMCS version 7.5 has been completed, you may switch to a PHP 7.1 or 7.2 environment is desired.
      It may be necessary to contact your server admin/hosting provider to make these configuration changes.
      More information: http://help.whmcs.com/m/75601/l/851363-troubleshooting-a-the-file-path-to-whmcs-index-php-is-corrupted-error
    • By Scolpy
      Today ionCube released v4.5.0 which compatible with PHP 5.5.X.
      So I updated my PHP 5.4.x to 5.5.x and installed the new loaders but when I try to access to the Administrator panel I got this error:
      Please know that before you update to PHP 5.5.x because WHMCS team need to the update WHMCS files in order support the new ionCube loaders.
    • By developer10
      I've already submitted a ticket to the support but still nothing from them. Everything else seems to be just alright but no tickets are arriving, an error message mentioning piping problem bounces back to the sender's email.
  • Recently Browsing   0 members

    No registered users viewing this page.


Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated