Jump to content

Recommended Posts

A fatal error occurred while fetching the update.

Please check to make sure your memory limits and execution time are set to the recommended values.

 

Have tried the update 6 times and get this error. The temporary updates folder is not in the html directory and it is set to CHMOD 0755. Also tried with 0777 and get this error every time.

Share this post


Link to post
Share on other sites

Hi Techdefy,

 

Thanks for getting in touch, sorry to hear you are having issues, please ensure:

 

You have a PHP Memory limit of at least 128MB (256MB if it is already 128)

You have a PHP Memory time out of at least 300 seconds

Share this post


Link to post
Share on other sites

Hi, I have this same error when trying to update.

 

I'm running PHP 7.0 with max_execution time: 300, Memory limit: 512m

Share this post


Link to post
Share on other sites

Hi,

Please open your browser's network analyser tool, then initiate the auto-update, and inspect the post to update.php.

Please let me know what response you receive there.

Share this post


Link to post
Share on other sites

scripts.min.js?v=3c55e4:4 POST https://******.com/******/admin/update.php net::ERR_SPDY_PROTOCOL_ERROR

send @ scripts.min.js?v=3c55e4:4

ajax @ scripts.min.js?v=3c55e4:4

pt.(anonymous function) @ scripts.min.js?v=3c55e4:4

(anonymous) @ update.php?nocache=3cPQkgYppL3eeFWO:120

n.complete @ scripts.min.js?v=3c55e4:3

u @ scripts.min.js?v=3c55e4:2

fireWith @ scripts.min.js?v=3c55e4:2

l @ scripts.min.js?v=3c55e4:1

pt.fx.tick @ scripts.min.js?v=3c55e4:3

setInterval (async)

pt.fx.start @ scripts.min.js?v=3c55e4:3

pt.fx.timer @ scripts.min.js?v=3c55e4:3

B @ scripts.min.js?v=3c55e4:1

r @ scripts.min.js?v=3c55e4:3

dequeue @ scripts.min.js?v=3c55e4:2

(anonymous) @ scripts.min.js?v=3c55e4:2

each @ scripts.min.js?v=3c55e4:1

each @ scripts.min.js?v=3c55e4:1

queue @ scripts.min.js?v=3c55e4:2

animate @ scripts.min.js?v=3c55e4:3

pt.fn.(anonymous function) @ scripts.min.js?v=3c55e4:3

(anonymous) @ update.php?nocache=3cPQkgYppL3eeFWO:107

dispatch @ scripts.min.js?v=3c55e4:3

g.handle @ scripts.min.js?v=3c55e4:2

 

edited out domain for post.

Share this post


Link to post
Share on other sites

I have this same error - "A fatal error occurred while fetching the update. Please check to make sure your memory limits and execution time are set to the recommended values.". I doubled all the recommended values but it still wouldn't update. I logged a ticket with my hosting provider yesterday (I have a reseller license) and they've come back with the following. Can you please advise if there is a fix, or if I should go ahead and do a manual (full) update? It doesn't look like there is a part-release available yet?
Cheers,
Nicky

Hi Nicky,

I've been looking into this but can't quite work out why the WHMCS auto-update feature isn't working. It may be worthwhile posting on the WHMCS forum as their reps are frequently on there.

https://whmcs.community/

I have uploaded the full 7.3 WHMCS version to "/home/websolut/whmcsdata/whmcs_v730_full.zip" should you like to try a manual update.

It appears that the server has sufficient network access to their update servers:

curl -I https://s3.amazonaws.com/releases.whmcs.com/packages.json
HTTP/1.1 200 OK

curl -I https://pki.whmcs.com/
HTTP/1.1 200 OK

..and all of your folders/filers appear to have correct permissions.

Perhaps this manual update will fix the auto-update feature, hopefully!

Regards,

Chris O'Neill
VentraIP Australia Technical Support
 

Share this post


Link to post
Share on other sites

Hi @Nicky

I'm sorry to hear you are experiencing issues with the auto updater. You can indeed apply the update manually using the full release version (because this is a feature release there isn't an incremental version available), but I'd like to assist you in resolving the problem.

Could you please open your browser's network analyser tool, run the auto-updater process, and then share the response data from the POST request made to the update.php file (see attached).

 

 

2017-10-08_1201_001.png

  • Thanks 1

Share this post


Link to post
Share on other sites

Sure, here you go. (Would appreciate if you don't approve this for public viewing if there are any security implications.)

<!DOCTYPE html>
<!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en-US"> <![endif]-->
<!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en-US"> <![endif]-->
<!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>


<meta http-equiv="set-cookie" content="cf_use_ob=0; expires=Mon, 09-Oct-17 05:28:07 GMT; path=/">


<title>www.websolutionz.com.au | 524: A timeout occurred</title>
<meta charset="UTF-8" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
<meta name="robots" content="noindex, nofollow" />
<meta name="viewport" content="width=device-width,initial-scale=1,maximum-scale=1" />
<link rel="stylesheet" id="cf_styles-css" href="/cdn-cgi/styles/cf.errors.css" type="text/css" media="screen,projection" />
<!--[if lt IE 9]><link rel="stylesheet" id='cf_styles-ie-css' href="/cdn-cgi/styles/cf.errors.ie.css" type="text/css" media="screen,projection" /><![endif]-->
<style type="text/css">body{margin:0;padding:0}</style>
<!--[if lte IE 9]><script type="text/javascript" src="/cdn-cgi/scripts/jquery.min.js"></script><![endif]-->
<!--[if gte IE 10]><!--><script type="text/javascript" src="/cdn-cgi/scripts/zepto.min.js"></script><!--<![endif]-->
<script type="text/javascript" src="/cdn-cgi/scripts/cf.common.js"></script>

</head>
<body>
<div id="cf-wrapper">

    

    <div id="cf-error-details" class="cf-error-details-wrapper">
        <div class="cf-wrapper cf-error-overview">
            <h1>
              <span class="cf-error-type" data-translate="error">Error</span>
              <span class="cf-error-code">524</span>
              <small class="heading-ray-id">Ray ID: 3aaeedced9ed51f1 &bull; 2017-10-09 05:27:37 UTC</small>
            </h1>
            <h2 class="cf-subheadline" data-translate="error_desc">A timeout occurred</h2>
        </div><!-- /.error-overview -->

        <div class="cf-section cf-highlight cf-status-display">
            <div class="cf-wrapper">
                <div class="cf-columns cols-3">
                  
<div id="cf-browser-status" class="cf-column cf-status-item cf-browser-status ">
  <div class="cf-icon-error-container">
    <i class="cf-icon cf-icon-browser"></i>
    <i class="cf-icon-status cf-icon-ok"></i>
  </div>
  <span class="cf-status-desc" data-translate="browser_desc">You</span>
  <h3 class="cf-status-name" data-translate="browser_label">Browser</h3>
  <span class="cf-status-label" data-translate="browser_status_label">Working</span>
</div>

<div id="cf-cloudflare-status" class="cf-column cf-status-item cf-cloudflare-status ">
  <div class="cf-icon-error-container">
    <i class="cf-icon cf-icon-cloud"></i>
    <i class="cf-icon-status cf-icon-ok"></i>
  </div>
  <span class="cf-status-desc" data-translate="cloud_desc">Melbourne</span>
  <h3 class="cf-status-name" data-translate="cloud_label">Cloudflare</h3>
  <span class="cf-status-label" data-translate="cloud_status_label">Working</span>
</div>

<div id="cf-host-status" class="cf-column cf-status-item cf-host-status cf-error-source">
  <div class="cf-icon-error-container">
    <i class="cf-icon cf-icon-server"></i>
    <i class="cf-icon-status cf-icon-error"></i>
  </div>
  <span class="cf-status-desc" data-translate="server_desc">www.websolutionz.com.au</span>
  <h3 class="cf-status-name" data-translate="server_label">Host</h3>
  <span class="cf-status-label" data-translate="server_status_label">Error</span>
</div>

                </div>
            </div>
        </div><!-- /.status-display -->

        <div class="cf-section cf-wrapper">
            <div class="cf-columns two">
                <div class="cf-column">
                    <h2 data-translate="what_happened">What happened?</h2>
                    <p data-translate="origin_timed_out">The origin web server timed out responding to this request.</p>
                </div>

                <div class="cf-column">
                    <h2 data-translate="what_can_i_do">What can I do?</h2>
                          <h5 data-translate="if_website_visitor">If you're a visitor of this website:</h5>
      <p data-translate="try_again_in_a_few">Please try again in a few minutes.</p>

      <h5 data-translate="if_website_owner">If you're the owner of this website:</h5>
      <p><span data-translate="524_owner_desc">The connection to the origin web server was made, but the origin web server timed out before responding. The likely cause is an overloaded background task, database or application, stressing the resources on your web server. To resolve, please work with your hosting provider or web development team to free up resources for your database or overloaded application.</span> <a href="https://support.cloudflare.com/hc/en-us/articles/200171926-Error-524" data-translate="addtl_troubleshooting">Additional troubleshooting information here.</a></p>
                </div>
            </div>
        </div><!-- /.section -->

        <div class="cf-error-footer cf-wrapper">
  <p>
    <span class="cf-footer-item">Cloudflare Ray ID: <strong>3aaeedced9ed51f1</strong></span>
    <span class="cf-footer-separator">&bull;</span>
    <span class="cf-footer-item"><span data-translate="your_ip">Your IP</span>: 124.189.146.4</span>
    <span class="cf-footer-separator">&bull;</span>
    <span class="cf-footer-item"><span data-translate="performance_security_by">Performance &amp; security by</span> <a data-orig-proto="https" data-orig-ref="www.cloudflare.com/5xx-error-landing?utm_source=error_footer" id="brand_link" target="_blank">Cloudflare</a></span>
    
  </p>
</div><!-- /.error-footer -->


    </div><!-- /#cf-error-details -->
</div><!-- /#cf-wrapper -->

Share this post


Link to post
Share on other sites

Hi,

Thanks for providing that information.

This is a Cloudlfare error page. If you disable Cloudlfare on your website temporarily and try again, what output do you get this time please?

Share this post


Link to post
Share on other sites

I disabled Cloudflare and that just caused a whole bunch of other problems including my main website no longer working. I've got a ticket running with my host too and now they're suggesting changing CNAME records and all this other stuff. I just wanted to update the freaking software! So far everything I've tried still won't let the update run, it continues to time out. In the process I've wasted several hours across 4 days and messed up things that were working fine before, just to try to auto-update one piece of software which still won't update. And now Cloudflare is back on and I have a HTTP500 error and can't see WHMCS at all, even though nothing else was changed! If I ever get it back working again, I'll just try a manual update. I really don't think it should be this difficult.

Share this post


Link to post
Share on other sites
1 hour ago, Nicky said:

I disabled Cloudflare and that just caused a whole bunch of other problems including my main website no longer working. I've got a ticket running with my host too and now they're suggesting changing CNAME records and all this other stuff. I just wanted to update the freaking software! So far everything I've tried still won't let the update run, it continues to time out. In the process I've wasted several hours across 4 days and messed up things that were working fine before, just to try to auto-update one piece of software which still won't update. And now Cloudflare is back on and I have a HTTP500 error and can't see WHMCS at all, even though nothing else was changed! If I ever get it back working again, I'll just try a manual update. I really don't think it should be this difficult.

Just to follow up, the 500 error was because the update started and did enough before it timed out, to mess everything up. I ended up having to do the manual update anyway! But it's all working now. Summing up - auto-update doesn't seem to work with Cloudflare. That's about 7 hours of my life I'll never get back. Cheers :/

Share this post


Link to post
Share on other sites

Hi Nicky,

I'm sorry to hear the auto-update process wasn't smooth for you, but you were able to complete the process eventually.

It would be interesting to see what entry was made in the server error logs when the 500 error occurred though.

Share this post


Link to post
Share on other sites

Hi John,

The 500 error was:

PHP Fatal error:  Interface 'Whoops\\RunInterface' not found

the same as documented here:

I followed that fix and managed to complete the update manually.

Cheers,
Nicky

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines