Jump to content
Sign in to follow this  
Hal9000

WHOIS Lookup Error for .store and .design

Recommended Posts

Hi there,

 

I noticed in my activity log that there are messages like this:

WHOIS Lookup Error for 'blablabla.store': error detail unknown

 

While .design is contained in the dist.whois.json, I added .store myself in whois.json

[
   {
       "extensions": ".shop",
       "uri": "socket://whois.nic.shop",
       "available": "DOMAIN NOT FOUND"
   },
{
       "extensions": ".store",
       "uri": "socket://whois.centralnic.com",
       "available": "DOMAIN NOT FOUND"
   }
]

 

Which looks correct to me.

Either way, the "error detail unknown" is not very helpful... what could be wrong?

Share this post


Link to post
Share on other sites

.store is correct and working...

 

FM1o1cY.png

 

.shop should be...

    {
"extensions": ".shop",
"uri": "socket://whois.nic.shop",
"available": "queried object does not exist"
   },

with regards to the error, that usually means that your server IP has been marked by CentralNic as an untrusted source (usually for making too many whois searches through their whois server) - if you contact CentralNic support, they should be able to reset that for you.

 

https://forum.whmcs.com/showthread.php?86494-New-gTLDs-Whois-Server&p=518326#post518326

Share this post


Link to post
Share on other sites

Thanks.

Found out that whois.nic.store also works.

 

[
   {
       "extensions": ".shop",
       "uri": "socket://whois.nic.shop",
       "available": "queried object does not exist"
   },
{
       "extensions": ".store",
       "uri": "socket://whois.nic.store",
       "available": "DOMAIN NOT FOUND"
   }
]

Share this post


Link to post
Share on other sites
Thanks.

Found out that whois.nic.store also works.

it's will do as it's just an alias to whois.centralnic.com - btw, .design is another CentralNic TLD too. :idea:

Share this post


Link to post
Share on other sites

Somehow centralnic is reeeally slow in replying, often resulting in timeout errors in WHMCS.

 

WHOIS Lookup Error for 'foo.store': Error: 110 - Connection timed out

 

I can do a whois in the server shell, it takes over 20 seconds until a reply comes in...

So I guess I will contact CentralNic support anyway, maybe they throttle my IP or something...

Share this post


Link to post
Share on other sites

it's happened to us a few times - CentralNic don't really want you using whois to check domain availability, but with WHMCS there isn't an alternative - unless you have a lookup provider that offer these TLDs.

 

"Connection Timed Out" is a sure-fire certainly that the IP is being blocked.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated