Jump to content
denully

Oops! Something went wrong and we couldn't process your request.

Recommended Posts

So i'm one of the lucky ones to have the "Oops! Something went wrong and we couldn't process your request." and be stuck with it. This (from what i have found so far) only happens under configproducts.php, i can see the page itself, but trying to add or edit products, gives the error every time.

 

  • I am running within the minimal WHMCS server requirements.
  • I have Enabled and Disabled Error reporting in PHP, both giving the same results.
  • I have Enabled and Disabled show errors (together with the above) and i still only see the "oops.....", however in the activity log it says: Error: exception 'Whoops\Exception\ErrorException' with message 'Undefined offset: 1' in /var/####/####/####/####/####/admin/configproducts.php:0 Stack trace: #0 /var/####/####/####/####/####/admin/configproducts.php(0): Whoops\Run->handleError(8, 'Undefined offse...', '/var/####/####...', 0, Array) #1 {main}
  • Which i unfortunately didn't understand much of.
  • I tried to roll back to version 7.1 where the issue wasn't and then try a Manual update (rather then automatic update) to 7.2.1 , however this didn't change anything.
  • I can't recall or recreate it, but at some point in all my clicking and testing i ended on a page giving me an error with something like: 'Class 'Smarty_Internal_ParseTree_DqContent' not found' in...... , i was unfortunately tired, annoying and worn out and went to bed then and now cant find that error again, but figured i would throw it in anyway.
  • To the above smarty error, i tried to delete the smarty folder under Vendor and reupload from whmcs full package again, making sure there was a Smarty_internal_parsetree file. The issue was still there after that, but again i can't seem to find it now.

 

I read some suggestions of updating PHP to version 7, which i have requested from the Host, but that wont be happening any time soon, as of now im running on PHP Version 5.6.30

 

any suggestions would be highly appreciated

Share this post


Link to post
Share on other sites

Seeing an Oops error page like this indicates an error occurred during the generation of the page. The error can be anything, from a simple notice or warning to a fatal error that halts execution. It's the PHP error reporting level on your server that determines which types of errors will trigger it.

 

In this case, it appears the error is just a low level warning and not something to be concerned about. It does however suggest your PHP error_reporting level on the server is a little high for a production environment and we would recommend reducing it in your servers php configuration to 0, or at least to exclude warnings and notices.

 

-Ed

Share this post


Link to post
Share on other sites
Posted (edited)

it has already been deactivated, yet the error was still there.

 

I will take it up with the server Tech, if they can see why its still showing reports then.

 

thanks.

Edited by denully

Share this post


Link to post
Share on other sites

i have the same problem

 

Oops!

Something went wrong and we couldn't process your request.

Please go back to the previous page and try again.

 

clients can not access their accounts and the worst part no one can place a new order.

 

ticket #SOR-913935 - error client area after update to 7.2

Share this post


Link to post
Share on other sites
i have the same problem

 

Oops!

Something went wrong and we couldn't process your request.

Please go back to the previous page and try again.

 

clients can not access their accounts and the worst part no one can place a new order.

 

ticket #SOR-913935 - error client area after update to 7.2

 

 

if you enable Error Logging and try again, do you also, i the log, see some issues with Smarty ?

 

I have unfortunately yet resolved my issue either, so just trying to see if we both have issues with Smarty and that might be whats causing all this.

Share this post


Link to post
Share on other sites

I resolved, I delete the LANG folder and I uploaded a new one again, the upgrade installation leave a langupdate.php file in the folder that it was causing the problem.

 

whmcs used to answer their support ticket faster now takes days.

Share this post


Link to post
Share on other sites
I resolved, I delete the LANG folder and I uploaded a new one again, the upgrade installation leave a langupdate.php file in the folder that it was causing the problem.

 

whmcs used to answer their support ticket faster now takes days.

 

ah glad it worked out, unfortunately the language fix didnt help with mine :(

and yea your right, the support/update package got more expensive and the speed of service dropped.

Share this post


Link to post
Share on other sites
Posted (edited)

Turns out the problem was a server module in whmcs, one we had for phpmumbleadmin. why it caused issues for normal products i dont know, as they had no connections what so ever.

Edited by denully

Share this post


Link to post
Share on other sites

+1 on this - I deleted a bunch of legacy/unnecessary modules from the Modules/Servers folder and the error was fixed. As you mentioned i don't know why either as they had no connections what so ever to any of the modules I was using, wasted a few hours on this one.

Share this post


Link to post
Share on other sites
your PHP error_reporting level on the server is a little high for a production environment

 

OMG!!!

 

If there are errors in the code, the solution is solve it, not hide it.

:twisted:

Share this post


Link to post
Share on other sites

Hello,

 

I can confirm this error.

 

I solved downgrading php to 5.6.

I was running 7 and could not run 7.1 due to ioncube problems.

 

Regards

Share this post


Link to post
Share on other sites
If there are errors in the code, the solution is solve it, not hide it

I think the point wasn't to hide it entirely, just from public visibility. ;)

You can still log errors without showing them on the page.

Share this post


Link to post
Share on other sites

Hi Guys, i also use WHMCS (V7.2.3) with the same problem with you,,,

Oke.... These bugs is patched now...

You just need Delete/Remove Norwegian.php&English.php in lang folder. ....

Share this post


Link to post
Share on other sites
You just need Delete/Remove Norwegian.php&English.php in lang folder. ....

Some of us will need at least one of those. My client base is almost entirely English speaking, for example.

Share this post


Link to post
Share on other sites
Hi Guys, i also use WHMCS (V7.2.3) with the same problem with you,,,

Oke.... These bugs is patched now...

You just need Delete/Remove Norwegian.php&English.php in lang folder. ....

and next time you run the WHMCS updater, it will restore both files back.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines