Jump to content

Recommended Posts

Since is seams WHMCS support is NOT in my time zone PST, since they only reply in the middle of the night. I figured I'd post in here to hopefully get a quicker reply. Ticket #FRW-619249

 

Upgrade error...

Script WHMCS\Installer\Composer\Hooks\ComposerInstallerHook::postUpdateCmd handling the post-update-cmd event terminated with an exception

 

Http error log...

PHP Fatal error:  Class 'Illuminate\\Container\\Container' not found in /home/dir/public_html/whmcs/vendor/whmcs/whmcs/vendor/whmcs/whmcs-foundation/lib/Container.php on line 0

 

Anyone else getting this issue? Or have any insight?

 

Everything I try gives the same fatal error.

Share this post


Link to post
Share on other sites

WHMCS 'official' support time is CST, as they're based out of TX , here in the US. However, they run individuals 24x7 .

 

Keep in mind, v7 was released just under 3 days ago, so, you're likely to see a ton of delays here. Support tickets will be inevitably overloaded, and staff will be pulling overtime to deal with the queues. I would (honestly) be thankful if you got a response in under 48 hours, given the massive update that is v7 :).

 

Bear with 'em, they'll get to you.

 

I just ran the update myself (from rc1 to gold) and no issues here, either.

Share this post


Link to post
Share on other sites
Since is seams WHMCS support is NOT in my time zone PST, since they only reply in the middle of the night. I figured I'd post in here to hopefully get a quicker reply. Ticket #FRW-619249

 

Upgrade error...

Script WHMCS\Installer\Composer\Hooks\ComposerInstallerHook::postUpdateCmd handling the post-update-cmd event terminated with an exception

 

Http error log...

PHP Fatal error:  Class 'Illuminate\\Container\\Container' not found in /home/dir/public_html/whmcs/vendor/whmcs/whmcs/vendor/whmcs/whmcs-foundation/lib/Container.php on line 0

 

Anyone else getting this issue? Or have any insight?

 

Everything I try gives the same fatal error.

 

 

Did you ever find a solution to this? I am having the same problem.

Share this post


Link to post
Share on other sites
Did you ever find a solution to this? I am having the same problem.

 

have the same problem too, happened during the update to 7.1.1!!!

 

Can someone help?

Share this post


Link to post
Share on other sites

I had the same error and noticed some incorrect file permissions on some of my config files. I don't know if this fixed the problem but it's fine now.

Share this post


Link to post
Share on other sites

I have the exact same error that occurred during upgrade from 7.1.1 to 7.1.2

 

PHP Fatal error: Class 'Illuminate\Container\Container' not found in /home/billingwhmcs/public_html/vendor/whmcs/whmcs/vendor/whmcs/whmcs-foundation/lib/Container.php on line 0

 

It looks like it has put nested folders in the vendor folder that wasn't like that in 7.1.1

 

I don't have a recent backup either. This is so much fun dealing with Fatal Errors that don't have a solution. :/

Share this post


Link to post
Share on other sites

Hi,

Please review the tblupgrades table, sort in date order, and then let us know the most recent entries from your last upgrade attempt.

This will provide more information on where the upgrade process failed.

Share this post


Link to post
Share on other sites

Fatal error: Class 'Illuminate\Container\Container' not found in /var/www/vhosts/theenergygrid.link/httpdocs/whmcs/vendor/whmcs/whmcs/vendor/whmcs/whmcs-foundation/lib/Container.php on line 0

 

The tblupgrades arrears to be empty.

The Error happened when I trie san Auto upgrade, but my logo.png file was write-only. I got an error message to this effect, changed the permissions, but cannot try again due to this error coming up whenever I try to access the site. Tried restoring from backup - no help.

Help?

Share this post


Link to post
Share on other sites
Posted (edited)

I actually have the same error in the server logs ever since upgrading to v7. This one:

 

PHP Fatal error: /whmcs-foundation/lib/Container.php on line 0

 

I had no errors while upgrading what so ever and v7 works fine. Except the server is constantly logging that same error you mentioned. Upgraded manually from v6.

 

- - - Updated - - -

 

I have the exact same error that occurred during upgrade from 7.1.1 to 7.1.2

 

PHP Fatal error: Class 'Illuminate\Container\Container' not found in /home/billingwhmcs/public_html/vendor/whmcs/whmcs/vendor/whmcs/whmcs-foundation/lib/Container.php on line 0

 

It looks like it has put nested folders in the vendor folder that wasn't like that in 7.1.1

 

I don't have a recent backup either. This is so much fun dealing with Fatal Errors that don't have a solution. :/

 

I also think this must be related to some moved file or path its not finding. It surely is not a corruption of files like WHMCS John mentioned here because I never had corruption of files the way I upload them and just to be sure I uploaded them twice.

 

The fact that more than one user is complaining they have the same error in their apache logs means it must be some file that WHMCS is not finding or was moved.

Edited by yggdrasil

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines