Jump to content
Sign in to follow this  
ragesw

New Security Update and Password Hashes

Recommended Posts

After upgrading to 5.1.9 my API code broke.

 

I tracked it down to the password hash I was generating from the user inputted password. It's not matching what is returned by the Get Client Details API call: http://docs.whmcs.com/API:Get_Clients_Details

 

I am hashing the user inputted password properly using the salt in the form of;

 

$newpassword = md5($salt.$request_password);

 

And it was working fine before the update.

 

Was there a change to the way passwords are hashed in 5.1.9?

 

Is anyone having a similar issue?

 

Thanks,

Paul

Share this post


Link to post
Share on other sites

This issue has been resolved. It was related to how the script was written and a possible change in the latest 5.1.9 update which broke it. Basically variable names were being sent with single quotes around them.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated