Jump to content
Sign in to follow this  
SVCode

PayPal Subscription IPN broken in 5.1.8

Recommended Posts

Any subscription based callbacks via IPN (subscription creation, completion, cancellation) do not work for me with 5.1.8 - anyone else seeing this? It returns a 406. Payment success seems to work fine.

 

I've had to roll back the 5.1.7 paypal.php callback file and all seems to be working again... not a good fix though.

 

- - - Updated - - -

 

P.S Please don't suggest Suhosin, mod_security...this is not the issue :)

Share this post


Link to post
Share on other sites

Same issue with 5.2.5 here. Checked apache error log, no errors there: not a mod_security issue, nor suhosin either.

Waiting for 5.2.6 to mature before trying to upgrade again.

Share this post


Link to post
Share on other sites

We upgraded from 5.1.7 to 5.1.8 then 5.1.9 and have the same issue, error 406....... not mod security issue....

 

Anyone else experiencing problems too?

Share this post


Link to post
Share on other sites

Hi John,

 

As per the support ticket where this link was provided, we have already mentioned this is not the issue, the link was visited prior to placing the support ticket in and checked... It still though is not working.

 

Regards

 

Lance

Share this post


Link to post
Share on other sites

I am also facing same issues since 2nd August, 2013.

And seems many people are having this issue. Please see - http://www.webhostingtalk.com/showthread.php?p=8798650#post8798650

 

There must be something has changed else there would not been so many people facing this issue.

 

 

 

Hi John,

 

As per the support ticket where this link was provided, we have already mentioned this is not the issue, the link was visited prior to placing the support ticket in and checked... It still though is not working.

 

Regards

 

Lance

Share this post


Link to post
Share on other sites

We have done all thats on the WHT link also.... still nothing........ its as though someones put up a massive firewall...

 

I have this evening escalated with Paypal also, even though they looked into this a few days ago for us too, spoke tonight with some of their merchant services.... as not getting much response apart from links from support....

 

Out of curiosity, what versions are you running, we have 5.1.9 and 5.2.4 (dev) that have both failed.

Share this post


Link to post
Share on other sites

Hi,

It's correct you see a 406 error when visiting the callback file in your browser directly, it's not a genuine callback so doesn't validate with PayPal, hence an error is displayed.

Share this post


Link to post
Share on other sites

As we have a complete blackout from paypal (not just subscriptions failing), we were provided a URL earlier today that we were unable to get too, this seemed to fail at telia.net in Sweden... Not sure if this related or not but have raised the failure points with paypal a few moments ago....... Will keep you posted as they may use same routing for their processing.

 

Lance

Share this post


Link to post
Share on other sites

Thanks Lance.

Please keep us updated.

This will help many people facing this issue.

 

Paypal has now disabled Paypal IPN notification to one of our account completely due to too many failures :(

Share this post


Link to post
Share on other sites

Well we have changed one of our servers IPs and we now get the paypal balance and transaction lookup is now working....... IPN though still fails......

Share this post


Link to post
Share on other sites

Any update on this? Paypal is not working for me at all (i.e. payments made by clients do not register as paid). Need this resolved ASAP!

Share this post


Link to post
Share on other sites
we ended up changing our servers main IP address

 

Thank you, but it sounds like an insane thing to do to 'fix' this bug. Has anyone else been successful in fixing this with any other method?

Share this post


Link to post
Share on other sites

it was affecting too many people and everyone was saying no issues anywhere.... if we hadn`t of made changes then we`d still have the problem.

Share this post


Link to post
Share on other sites

Thanks Lance, but we are still facing this same issue. I cannot change my server's IP. Anyone with a different (more realistic/do-able for most people) fix?

Share this post


Link to post
Share on other sites

int, hope you find out whats causing it, no one could for us, hence the need to change ips.... would have much preferred a different solution.

Share this post


Link to post
Share on other sites

Hi,

Same issue here, sometimes PayPal transactions are marked as "Completed", but most time they are marked as "Pending". Then I need manually add payments to the invoice to mark it as Paid.

Share this post


Link to post
Share on other sites
int, hope you find out whats causing it, no one could for us, hence the need to change ips.... would have much preferred a different solution.

 

Just a guess, but if you have to change your i.p., it sounds like Paypal may have blacklisted it?

Share this post


Link to post
Share on other sites

same issue here for me, WHMCS 5.2.7

 

Paypal payments are not being registered by WHMCS and invoices are not being marked as 'paid'

Share this post


Link to post
Share on other sites
Paypal payments are not being registered by WHMCS and invoices are not being marked as 'paid'
Hi,

Please navigate to Billing > Gateway Log. Do you see any record of the payments? If so please copy the debug data and the result into your reply.

 

If there are no entries please double-check the IPN settings in your account are configured per our documentation @ http://docs.whmcs.com/PayPal

 

If that's configured correctly already, in your PayPal account navigate to History > IPN History and click the Message ID link corresponding to a transaction not recorded in WHMCS. The details on the Message ID page should shed some light on the matter.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated