Jump to content
daboolz

Can't login to admin area

Recommended Posts

Hello everybody,

 

I have a problem with WHMCS, and hoping someone here may be able to help me.

 

I recently upgraded to v 5.1.2. Upgrade went well, and I was able to login to admin normally afterward.

 

However, today, when I tried to login to admin, although I'm 100% sure that username and password are correct, I could not login to admin in WHMCS. At all. I could error out if I gave the wrong password, but I could not actually login if I was right. It always automatically comes back to the ../admin/login.php page, as if I had just open it.

 

I tried the "forgotten password" function, it was working. Password was reset, and new password was sent to email. But still I can't login.

 

I tried 3 different browsers, and clean all cache before logging in, still not working

 

Strangely enough, I could login if I use proxy to login. I used ultrasurf. I also had someone access it from outside, and it was accessible.

 

Can anyone here help determine what the problem could be? Thanks in advance for your help.

 

Regards,

Greg

Share this post


Link to post
Share on other sites
Guest benpotter1991

I also seem to have this problem exactly how you mention. I submitted a ticket and a couple of the support staff had no problems logging into my admin area. Just seems to be me that has this problem.

 

The only (very weird) way I can get around it is to be logged in as a client on my website, then try to log into my admin section and then it works fine.

 

I am not sure what is wrong, and tbh given up trying to sort it out!

Share this post


Link to post
Share on other sites

Are you using a custom admin directory?

If so make sure you have uploaded the /admin files to the correct location ;)

This also shows no error message when loggin in, either using the correct details or not..

 

If not using a custom directory then try with "Remember me until I logout." ticked and no ticked.

With it unchecked it uses sessions, with it checked it uses cookies. If one works and not the other then it indicates a issue with the server.

 

Failing to find the problem yourself using this info then open a support ticket :)

 

Dan

Share this post


Link to post
Share on other sites
Are you using a custom admin directory?

If so make sure you have uploaded the /admin files to the correct location ;)

This also shows no error message when loggin in, either using the correct details or not..

 

Yes, I'm using custom admin directory, but I made sure the admin files are uploaded to the right folder. So no problem there.

 

If not using a custom directory then try with "Remember me until I logout." ticked and no ticked.

With it unchecked it uses sessions, with it checked it uses cookies. If one works and not the other then it indicates a issue with the server.

 

Failing to find the problem yourself using this info then open a support ticket :)

 

Dan

 

I tried the "Remember me until I log out" both ticked and unticked too, but no dice.

 

The other strange thing is, apart from the fact that I can login just find at home using a proxy server (ultrasurf), turns out I can also login just fine from my office. But still, can't do it at home without proxy. Same laptop.

 

Could this be an ISP issue? DNS problem? I'm confused.

Share this post


Link to post
Share on other sites

Just had a thought, is there a feature on WHMCS where it only allows connection from a certain IP? I upgraded WHMCS at the office. But that doesn't explain why I can login via a proxy server out of US... hmm..

 

Could my ISP's IP at home somehow blacklisted, and WHMCS doesn't allow connection from a blacklisted IP address?

Share this post


Link to post
Share on other sites
Go to Phpmyadmin > Database > tbladmins > edit yours >

 

password varchar(32) MD5 Your new password.

 

then click save.

 

then try and log in again.

 

 

Or

 

Phpmyadmin > Database > tblbannedips > check if your IP is in the list probably the last record. If it is click on delete (Red button)

 

Thanks for your input, however I know the problem is not the password, I know my password is correct. I also checked the banned IPs table, it's empty.

 

Hi,

WHMCS doesn't currently have a feature to only permit logins from certain IPs. However you could try ticking the Setup > General Settings > Security tab > Disable Session IP option to see if that helps: http://docs.whmcs.com/Security_Tab#Disable_Session_IP_Check

 

This could be it. I've disabled session IP option, and I'll try logging in again as soon as I get home. Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated