Jump to content
atmark

Addon Translate (FREE)

Recommended Posts

Hi!

 

Allow me to introduce our development.

This Addon is intended to edit and verify that all the variables in all the language files.

There is a convenient grouping and pagination. There is a search.

For convenience, we have added service "Translate Google".

Of course he only help.

 

If you have any questions or suggestions, please do not hesitate to ask.

 

http://www.whmcs.com/members/communityaddons.php?action=viewmod&id=146

Download - http://atmark.ru/client/whmcs_translate.php?language=English

Edited by atmark

Share this post


Link to post
Share on other sites

Hi

 

I have this message after tried to translate :

 

ERROR copy file ../lang/French.txt...

 

CRITICAL ERROR!!!

The following variables are used both types of quotes - " and ' .

Variable: $_LANG["sslserverinfodetails"]

Original text: You must have a valid \"CSR\" (Certificate Signing Request) to configure your SSL Certificate. The CSR is an encrypted piece of text that is generated by the web server where the SSL Certificate will be installed. If you do not already have a CSR, you must generate one or ask your web hosting provider to generate one for you. Also please ensure you enter the correct information as it cannot be changed after the SSL Certificate has been issued.

Translate text: Vous devez avoir un \"CSR\" (Certificate Signing Request) valide afin de pouvoir configurer votre ceftificat SSL. Le CSR est un texte encrypté généré par le serveur web où le certificat sera installé. Si vous n'avez pas votre CSR, vous devez le générer ou demander à votre hébergeur de le générer pour vous. Assurez vous également de l'exactitude des informations entrées, car elles ne peuvent être changés après le déploiem

 

Please correct your entries. After correcting the opportunity to save your changes resumes.

Share this post


Link to post
Share on other sites

The answer you were given by email.

Using the words n'avez l'exactitude apostrophes and quotation marks \ "CSR \".

Replace quotes \"CSR \" in apostrophes 'CSR'.

You can specify them by pairing ' ' CSR ' '

Share this post


Link to post
Share on other sites

Hello!

The new version is available for V5.

http://www.whmcs.com/members/communityaddons.php?action=viewmod&id=146

In addition to revised code to the new version, changes are made in automating the translation.

Now, instead of Google translate service will be used by Bing .

Reason - http://code.google.com/intl/ru-RU/apis/language/translate/overview.html

Edited by WHMCS Andrew
External URLs not allowed

Share this post


Link to post
Share on other sites

It cut the end of the words when they contains non english chars like ő, ű, Ő, Ű, etc. I would like to use this great addon for hungarian translation. Can you help me please? (I have no problem with the Admin translation addon...)

 

The page and the database are in utf8. :-)

 

Regards, Zoltan

Share this post


Link to post
Share on other sites

Hi zkorosi

 

I found no problems in the module.

I created the file and automatically hungarian.php translated several phrases.

$_LANG["accountinfo"] = "Fiókadatok";

$_LANG["accountstats"] = "Fiók-statisztika";

$_LANG["addfunds"] = "Pénzt";

$_LANG["addfundsamount"] = "Összeg hozzáadása";

$_LANG["addfundsmaximum"] = "Maximális letétbe helyezése";

$_LANG["addfundsmaximumbalance"] = "Maximális egyenleget";

$_LANG["addfundsmaximumbalanceerror"] = "Legnagyobb egyenleg összege";

$_LANG["addfundsmaximumerror"] = "Maximális letét összege";

$_LANG["addfundsminimum"] = "Minimum befizetés";

 

Please send me your language file that you created hungarian.php

Perhaps your language file encoding not UTF-8 without DOM

(The database in the module is not used)

Share this post


Link to post
Share on other sites

очень жаль, полезный модуль, на Version: 5.0.3 тоже невидно его после установки :(

Share this post


Link to post
Share on other sites

А вы его активировали?

**********/client/admin/configaddonmods.php

 

Модуль установлен на более 500 биллингах.

Share this post


Link to post
Share on other sites
I downloaded translate module from http://atmark.ru/client/whmcs_translate.php and followed the instructions in readme_eng.txt file. When I login to admin cp >> settings >> addon modules, I don't see translate module. I am using whmcs 5.0.3.

 

Please advise.

 

You have solved the problem of access rights to the addon?

 

If you have questions - contact our technical support.

http://atmark.ru/client/submitticket.php

Share this post


Link to post
Share on other sites
can anyone confirm, does this work for WHMCS 5.0.3?

 

Addon works fine for 5.0.3

If you have any problems or questions - please contact us.

Share this post


Link to post
Share on other sites
1. Copy the folder with the files in "(your-WHMCS)"

2. In the file "configuration.php" make additional variables to configure the module.

$mod_translate['backup'] = 'yes';   	   // yes | no // create backup copy
$mod_translate['format'] = 'Y-m-d_H:i:s';  // format name backup copy file. //See - http://ru2.php.net/manual/en/function.date.php
$mod_translate['field'] = 90;		       // field width
$mod_translate['page'] = 25;        	   // rows per page

Warning! If you accept these default values, then this step can be skipped.

3. In the file "(your-WHMCS)/admin/templates/(your-template)/header.tpl", add between <head> and </head>, the line:
<script type="text/javascript" src="../includes/jscript/jtranslate.js"></script>

4. In the file "(your-WHMCS)/modules/admin/translate/settings.php" - is an array with the names of languages and language codes used in Google.
The language names should be consistent with the names of the language files used in WHMCS.
Sample: Portuguese-pt -> Portuguese-pt.txt
You may change еhis list  .
----------------------------------
!!!!!!!!!!!!!!!!!!!!
Get appID site http://www.bing.com/developers/
and edit the file translate_api.php
!!!!!!!!!!!!!!!!!!!!

 

i have done all of above, these are instructions from readme, but i think there is an issue somewhere in these steps, because i cant get it to work

Share this post


Link to post
Share on other sites
Hi zkorosi

 

I found no problems in the module.

I created the file and automatically hungarian.php translated several phrases.

$_LANG["accountinfo"] = "Fiókadatok";

$_LANG["accountstats"] = "Fiók-statisztika";

$_LANG["addfunds"] = "Pénzt";

$_LANG["addfundsamount"] = "Összeg hozzáadása";

$_LANG["addfundsmaximum"] = "Maximális letétbe helyezése";

$_LANG["addfundsmaximumbalance"] = "Maximális egyenleget";

$_LANG["addfundsmaximumbalanceerror"] = "Legnagyobb egyenleg összege";

$_LANG["addfundsmaximumerror"] = "Maximális letét összege";

$_LANG["addfundsminimum"] = "Minimum befizetés";

 

Please send me your language file that you created hungarian.php

Perhaps your language file encoding not UTF-8 without DOM

(The database in the module is not used)

 

Hello,

 

I have exactly the same problem with the FR language with a default installation.

Share this post


Link to post
Share on other sites
Hello,

 

I have exactly the same problem with the FR language with a default installation.

 

This is a problem when using quotation marks in a row at the same time of two types - single and double.

Use quotation marks in a string of only one type.

 

If you need additional assistance, please contact us at support.

Share this post


Link to post
Share on other sites

when i select the source and destination language it opens up as should and then when i edit and save i see the the Hebrew letters but when i edit again the old edit getting scrummble and sometimes i see ???? instead Hebrew latter

i believe the problem is in the saving process which convert the Hebrew letters to something else.

 

p.s

i open a ticket at your site

Share this post


Link to post
Share on other sites
same problem with the FR language with a default installation

Please send in support your language file.

Share this post


Link to post
Share on other sites

The error message specifically created.

The problem is that in the string of your language uses just two types of quotes. Single and double.

 

Single quotes (apostrophes) are used in speech

n'avez & l'exactitude

 

Double in the \ "CSR \"

 

 

Since the the words can not replace an apostrophe, you must replace the double quotes \ "CSR \"

 

on the 'CSR'

or ' ' C S R ' ' (spaces between the symbols for clarity) (if you want to have the appearance of the double quotes)

 

 

Solutions for processing in a row <input> entry form immediately double and single quotes I have not found.

I would be happy for your tips.

Edited by atmark

Share this post


Link to post
Share on other sites

Problem solved

 

Thank you @atmark for your help

Great support

 

here is the solution as @atmark recommend

 

1> in the .htaccess file add the line:

 

AddDefaultCharset UTF-8

 

2> in the configuration.php file add this :

 

mb_internal_encoding("UTF-8");
mb_regex_encoding("UTF-8");

Share this post


Link to post
Share on other sites

Hi

 

Can you please renew addon download link

 

Thank you very much

Share this post


Link to post
Share on other sites
Problem solved

 

Thank you @atmark for your help

Great support

 

here is the solution as @atmark recommend

 

1> in the .htaccess file add the line:

 

AddDefaultCharset UTF-8

 

2> in the configuration.php file add this :

 

mb_internal_encoding("UTF-8");
mb_regex_encoding("UTF-8");

 

my configuration.php looks liek this:

<?php
$mod_translate['backup'] = 'yes';   	   // yes | no // create backup copy
$mod_translate['format'] = 'Y-m-d_H:i:s';  // format name backup copy file. //See - http://ru2.php.net/manual/en/function.date.php
$mod_translate['field'] = 90;		       // field width
$mod_translate['page'] = 25;        	   // rows per page
$license = 'fdfsdfdsf5455445';
$db_host = 'localhost';
$db_username = 'username_whmcs';
$db_password = 'myownpassword';
$db_name = 'name_whmcs';
$cc_encryption_hash = '3g4j3g23jh53jh52jj525g235h2hj5g235g23jh52g35g2h352h3j';
$templates_compiledir = '/home2/username/templates_c/';
$mysql_charset = 'utf8';
$attachments_dir = '/home2/username/attachments/';
$downloads_dir = '/home2/username/downloads/';
?>

 

so how exactly should my new configuration look like, because i am having problems with utf-8 šđžčć characters.?

 

Thank you in advance

Dan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

By using this site, you agree to our Terms of Use & Guidelines