Jump to content

dimitrifrom31

Member
  • Content Count

    137
  • Joined

  • Last visited

Community Reputation

0 Neutral

About dimitrifrom31

  • Rank
    Level 2 Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hi, As you may know there was a fire in an OVH datacenter. Due to this I have several machines down and thus several customers without service at the moment. I would like to add extra days to these customers (first to compensate the down time and later again as a gift for the issue). I ma hosting game servers and Im using the whmcs "domain" field to identify their game servers by ip and port. So I was thinking of a mysql query such as: UPDATE `tblhosting` SET `nextduedate` = DATE_ADD(`nextduedate` , INTERVAL 30 DAY) WHERE `domain` LIKE '%123.123.123.123%' OR `domain` LIKE '%456.456.456.456%' ; Now my concerns: - this will post pone next due date but if the customers have an existing unpaid invoice I assume this will generate another invoice on next daily cron job and thus charge them twice for the service instead of adding free days. Should I update all the invoices for these customers to mark them as cancelled ? - I see there is also a 'nextinvoicedate' column in the 'tblhosting' table. Should I also update the nextinvoicedate or is that done automatically when updating nextduedate ? thank you
  2. Hi, I have been using TCadmin v1 advanced module for years now but recently upgraded whmcs to 7.10.2 and PHP to 7.4.15 One of my modules however has been quite abandoned and I am looking for someone to update its code to make it fully compatible again. I attached the files if you wish to take a look. Please PM me your quote for the job. It is basically one file code to update. Thank you tcadmin_advanced.zip
  3. Hi, Im looking for someone to update my 7.1.0 template to be 8.0.3 compatible. The template has been partially updated for 7.10.2 but issues remain such as the cliient reset password feature that does not work due to custom header/footer. Please send me a quote.
  4. thanks for your help, unfortunately I was unable to fix my issues so I'm looking for someone to quote me to update my template so it is 8.0.3 compatible. If anyone is interested in such a job please give me a quote for the work.
  5. Hi, After upgrading whmcs from 7.1 to 7.10.2 my custom template has required quite a few adjustments. I am still getting an issue with the "save modifications" button on the client password change page that cannot be clicked ant it is caused by my custom head.tpl I read that custom css and javascripts require to be removed from head.tpl and included instead but I am still getting issues after doing so. This is my original (before moving out customizations) head.tpl, if someone could pinpoint me the different parts that I need to move/remove that would be greatly apreciated: {if $language eq 'French' or $language eq 'french'} {assign var="activelanguage" value="french"} {elseif $language eq 'English' or $language eq 'english'} {assign var="activelanguage" value="english"} {elseif $language eq 'Spanish' or $language eq 'spanish'} {assign var="activelanguage" value="spanish"} {else} {assign var="activelanguage" value="english"} {/if} <!-- Styling --> <link href="//fonts.googleapis.com/css?family=Open+Sans:300,400,600|Raleway:400,700" rel="stylesheet"> <link href="{$WEB_ROOT}/templates/{$template}/css/all.min.css?v={$versionHash}" rel="stylesheet"> <link href="{$WEB_ROOT}/assets/css/fontawesome-all.min.css" rel="stylesheet"> <link href="{$WEB_ROOT}/templates/{$template}/css/custom.css" rel="stylesheet"> <!-- HTML5 Shim and Respond.js IE8 support of HTML5 elements and media queries --> <!-- WARNING: Respond.js doesn't work if you view the page via file:// --> <!--[if lt IE 9]> <script src="https://oss.maxcdn.com/libs/html5shiv/3.7.0/html5shiv.js"></script> <script src="https://oss.maxcdn.com/libs/respond.js/1.4.2/respond.min.js"></script> <![endif]--> <script type="text/javascript"> var csrfToken = '{$token}', markdownGuide = '{lang key="markdown.title"}', locale = '{if !empty($mdeLocale)}{$mdeLocale}{else}en{/if}', saved = '{lang key="markdown.saved"}', saving = '{lang key="markdown.saving"}', whmcsBaseUrl = "{\WHMCS\Utility\Environment\WebHelper::getBaseUrl()}", requiredText = '{lang key="orderForm.required"}', recaptchaSiteKey = "{if $captcha}{$captcha->recaptcha->getSiteKey()}{/if}"; </script> <script src="{$WEB_ROOT}/templates/{$template}/js/scripts.min.js?v={$versionHash}"></script> {if $templatefile == "viewticket" && !$loggedin} <meta name="robots" content="noindex" /> {/if} <link rel="shortcut icon" type="image/x-icon" href="{$WEB_ROOT}/templates/{$template}/img/favicon.ico" /> <link href="{$WEB_ROOT}/templates/{$template}/{$activelanguage}/css/style.css" rel="stylesheet" type="text/css" /> <link href="{$WEB_ROOT}/templates/{$template}/{$activelanguage}/css/menu.css" rel="stylesheet" type="text/css" /> <link href="{$WEB_ROOT}/templates/{$template}/{$activelanguage}/css/slider.css" rel="stylesheet" type="text/css" /> <link href="{$WEB_ROOT}/templates/{$template}/{$activelanguage}/css/button.css" rel="stylesheet" type="text/css" /> <script type="text/javascript" src="{$WEB_ROOT}/templates/{$template}/{$activelanguage}/js/jquery.cycle.all.js"></script> <script type="text/javascript" src="{$WEB_ROOT}/templates/{$template}/{$activelanguage}/js/organictabs.jquery.js"></script> {literal} <script type="text/javascript" language="javascript"> $(document).ready(function(){ $('#bannerSlides').cycle({ fx: 'fade',// name of transition effect (or comma separated names, ex: 'fade,scrollUp,shuffle') sync: 1, width: '100%', height: 0, pager: '#slider-nav', speed: 1000, // speed of the transition (any valid fx speed value) timeout: 6000, // milliseconds between slide transitions (0 to disable auto advance) startingSlide: 0, // zero-based index of the first slide to be displayed pauseOnPagerHover: 0, // true to pause when hovering over pager link next: '#next', // element, jQuery object, or jQuery selector string for the element to use as event trigger for next slide prev: '#prev' // element, jQuery object, or jQuery selector string for the element to use as event trigger for previous slide }); $('#hide').click( function () { //show its submenu $(".dropdown_link").stop().slideToggle(100); }); $('#hide2').click( function () { //show its submenu $(".dropdown_link2").stop().slideToggle(100); }); }); </script> <script> $(function() { $("#tab_con1").organicTabs({ "speed": 200 }); }); </script> <style> .topbox4chat:hover { opacity:0.7!important; transition:opacity .55s ease-in-out!important; -moz-transition:opacity .55s ease-in-out!important; -webkit-transition:opacity .55s ease-in-out!important ; cursor:pointer; } </style> {/literal} {if $filename eq 'index'} <link rel="stylesheet" href="{$WEB_ROOT}/templates/{$template}/{$activelanguage}/carousel/util.carousel.css" /> <link rel="stylesheet" href="{$WEB_ROOT}/templates/{$template}/{$activelanguage}/carousel/util.carousel.skins.css" /> {/if} <!-- Custom Styling --> <link href="{$WEB_ROOT}/templates/{$template}/css/custom.css" rel="stylesheet"> {if $clientareaaction eq 'invoices'} {if $activelanguage eq 'spanish'} {literal} <style> .btn-group-sm>.btn, .btn-sm { font-size: 9px!Important; } </style> {/literal} {/if} {if $activelanguage eq 'french'} {literal} <style> .btn-group-sm>.btn, .btn-sm { font-size: 8px!Important; } </style> {/literal} {/if} {/if}
  6. I will certainly take backups but I was wondering if upgrading from my version directly to the latest was in theory even possible I am using a couple of non vital third party payment gateways I will have to update. I believe I cannot simply update the payment gateways modules without updating whmcs ?
  7. Hi, I haven't updated whmcs for a while (mostly fearing to break addons compatibility) but due to changes in paypal/stripe API's I am now forced to if I don't want to get into payment issues. I was wondering if there was a risk to upgrade directly from my version to latest or if I had to upgrade progressively like 7.2, 7.3 etc to 7.10.2 Any recommendation? Thanks!
  8. I contacted him 4 days ago, no answer yet. I am currently stuck with a non working cpanel module causing automated setups/suspensions and deletions to fail.
  9. I run WHMCS 7.1.2 and cpanel module stopped working too. Mind sharing a solution as I do not wish to update my WHMCS for various compatibility reasons ( web hosting is not my main business and this would break some important compatibilities)? Thanks
  10. Hi, As the cpanel theme "x3" is now outdated I changed the default theme in WHM/Cpanel to paper_lantern however when whmcs creates a new account it is parsing the theme to set and has x3 as value. Example of the module log: username=deathlin&password=hidden%21&domain=hidden.fr&savepkg=0&quota=2048&cgi=1&contactemail=hidden%40gmail.com&cpmod=x3&maxftp=unlimited&maxsql=unlimited&maxpop=unlimited&maxsub=unlimited&plan=roxwebfr_standard&api.version=1&reseller=0 Where can I edit the value parsed to replace x3 by paper_lantern ? Thank you - - - Updated - - - Self answering: You have to click the advanced settings on the module settings tab for the product in question
  11. I got a similar issue, the cron job often hangs during suspensions / teminations so I had to set them to run seprately: cron.php do --AutoTerminations --FixedTermTerminations I got another bug when the cron completes (sometimes still does not) I receive a second cron summary email 1 hour after the standard one with only "0" in values and where my company name is replaced by "Company Name"
  12. Does it have similar features and if yes are you selling copies ? All I am looking for is ability for user to manage DNS zones from customer portal with SRV records support.
  13. Hi Chris, Yes I have been told so however that was also the case in August 2014 and the module was fixed only in October 2016... more than 2 years later, and broke again in November 2016. The OVH API documentation was released long time ago, the problem is that instead of preparing future changes updating the module, whmcs is only fixing afterwards (with years of delay in that case). I can't explain why third party modules are updated more frequently than the official ones.
  14. The OVH registrar module has almost never worked for the past 3 years. It has been working for few days after v7 release but it is now broken again as it was coded based on the ovh old (reaching EOL) SOAPI. As a consequence I have been processing domain orders manually which is a real nightmare not to mention I purchased a whmcs owned license then renewed my support & updates addon to update to v7 but also the upgrade service. All that money to end with a manual process and whmcs does not seem to make it a priority so I might wait about 2 years again to get a fix that will get released when OVH will start using a new API. I have a ticket with whmcs and I submitted a bug report but I felt like posting here because I have been ways too much patient with this now. It should be time to stop trying to offer fancy features and focus instead on getting the core features working properly (I got quite a few bugs on v7 and I see Im not the only one when I read these forums). Thank you for reading.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated