Jump to content

John Kennedy

Senior Member
  • Content Count

    36
  • Joined

  • Last visited

Community Reputation

0 Neutral

About John Kennedy

  • Rank
    Member
  1. Thanks for that! I believe adding a hook for a single file would be a better solution in the long run as I won't have to rewrite the hook every time I want change things to make them more readable or stand out more. <?php function admin_custom_css_hook($vars) { $currenttemplate = $vars['template']; $head_return = ''; $head_return = '<link href="templates/'.$currenttemplate.'/custom.css" rel="stylesheet" type="text/css" />'; return $head_return; } add_hook("AdminAreaHeadOutput",1,"admin_custom_css_hook"); Should give me a clean option.
  2. Trying to change the style of quoted text in the Notes tab in the Admin area. It looks like the text is wrapped in the <blockquote> tag with no id, class or any other identifiers. Is there anything specific that needs to be written in custom.css? Adding blockquote style doesn't do anything at all. Tested by editing blockquote style via inspecting the element and that changes the text just fine.
  3. I do want them to show up in the admin area, so I made them "Admin only". From what I understand, the hook will only affect listed CFs. So I don't make them Admin only and add them to the hook array for them to show up, but be read only? I was thinking of taking it a bit further actually - one of the fields is a unique link that I add directly into the database via a synch script, and I want that to be clickable on the primary sidebar. But this will do for now. I already checked one of your older post for the sidebar thing:
  4. Looks like I'll need to modify/add a few more things before I can have these custom fields displayed where I want them. Thanks for the info.
  5. I know they show up automatically when added but, when done that way, they can be edited. I wan't to change the template so it only shows a set of certain fields as text instead of input boxes. This is the template I'm talking about: # ls -liah | grep details -rw-r--r-- 1 whmcs whmcs 7126 Apr 2 16:47 clientareadetails.tpl Edit: I think I know what I'm doing wrong. This template is used when editing the customer profile. Guess, I'll keep digging, maybe I just need to use a different area to show the fields.
  6. Looking to display a few read-only custom fields in client area. I tried putting the fields in as per the documentation, but it doesn't seem to work. I seem to be missing something, but can't figure out what exactly.
  7. I'm trying to set up short term promotions (only 3 cycles) and apply them to existing products. The issue is whenever I generate an invoice with the said promotions applied to products, those product prices are reset to default and the promo code is wiped off. Original Pricing: Promotion code applied: Invoice generated: Pricing reset to default, no promo code: Not sure why this is happening, but it's making it impossible to apply short term discouns to existing services. The issue is similar to below, but not the same
  8. Anyone looking to do the same: update the last call to "InvoiceCreation" add_hook("InvoiceCreation",1,"generate_custom_invoice_number_hook"); @brian! Thanks for all the help! You're a legend.
  9. OK, got it working, but now I got a new problem - I need the same to work for manual invoices after having them published. Sometimes we need to backdate invoices and the only way to do it is to create an invoice, publish it without sending, change the dates and only them email it. This hook doesn't work it you publish without sending it right away. Can it be changed to something like "InvoiceCreationPostCreate"? What will it break if it can?
  10. This is also what I'm seeing after rewriting everything: Still doesn't work 😞
  11. Guessing it's safe to assume something funky is going on with the encoding here. I've tried uploading/creating the file numerous times - either pasting or typing it out. The only thing I haven't tried yet is using the hosting platform editor to create the hook.
  12. Lol no 😄 This is fucked up. All other hooks in that folder work fine
  13. Tried that before reuploading - didn't work. I'll try changing the var altogether to something else. Edit: nope.
  14. OK, this is bizarre - copied and pasted again, saved as UTF-8, uploaded into hooks. Still doesn't work.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated