Jump to content

poliquinp

Newbie
  • Content count

    10
  • Joined

  • Last visited

Community Reputation

10 Good

About poliquinp

  • Rank
    Newbie
  1. Submit button in register always stays disabled

    Yes you can mark this as close I finally founded that the javascript was setting disabled=disabled from two differents sources.
  2. We just found that if you have this checked in the product configuration the "config page" / "cart" won't be updated when you will click on "Order Now" Not sure if it was intetional but it gaves us alot of trouble today
  3. Hello, We just discover that when we click on Order Now from the cart gid X the next step showing the configuration does not show the right information. It "cache" or "bug" because sometimes, it is still the old information. For example : cart.php?a=add&pid=47 will bring me on the page cart.php?a=confproduct&i=6. But if I do "prev" in my browser and click on an other Order Now button it sometimes bring me on cart.php?a=confproduct&i=7 or it keeps me on cart.php?a=confproduct&i=6. * * What is &i=6 ? * * EDIT : After searches, it looks like the problem is on my side where the config page does not properly get updated.
  4. Hello, I have a new theme build for our WHMCS : https://gamehosting.co/register.php But when we try to create a new account, the button always stays disabled even if we fill all the datas. https://gamehosting.co/register.php?systpl=six It is working on the "Six" theme. * * Does some one know where I can find the javascript line that place or remove the disabled attribute?
  5. We do have a valid license. So how I could configure a dev without altering the customer view?
  6. Here we are I did yes called all includes files to my dev folder. But even if I deleted everything and only write Hello World or {debug} nothing happend still. Very strange
  7. Hello, We are trying to complete the editing of the last orderform template for our cart process and it is the complete.tpl. First, we copied the exact file from standard_cart/complete.tpl and placed it in our dev folder. After, when we use this link to complete order (whmcs/cart.php?a=complete&carttpl=dev&systpl=dev) we recive the email confirmation but we fall on a blank page. But if we write (whmcs/cart.php?a=complete&carttpl=standar_cart&systpl=six) as a default value, we see the Paypal redirection page. Also, if I do this link (whmcs/cart.php?a=complete&carttpl=standard_cart&systpl=dev) I get nothing also. So I think it might be something in the template folder directly that I am missing. Any clue where I could fix this? - - - Updated - - - I did not found the "edit" button so pardon me ! As I mentionned above, when I set the six template and standar_cart cart template everything is fine. If I set dev as template, nothing works. So I was thinking about the fact that I might be missing some includes files or folder. I looked in the six folder, and I saw the oauth and store folders. Does anything of this could resolve my problem?
  8. Hello! Ya I could test this. So I would need to do something like ?systpl=dev&carttpl=dev for example? I'm at 95% completed for the development. Was just asking if their was any way to avoid this problem for next time.
  9. Hello, We are developping our own new theme for WHMCS and we would like to know if their is any possible way to set a different " Default Order Form Template " for users logged as Admin. In example, normal users would see " Modern " template and admins would see " New theme " template. I tried to do a quick search on the Web but found nothing really matching my request. * * I'm asking because while we dev, we kinda break the user experience on the other side for people who does not type "?systpl="
  10. Hello, I tried to look arround before posting but it did not helped me. I have created a new page named « games.php » where I do some sorts for custom queries and custom texts. But when it comes to change the language with the original language switcher, it does not work. I have to go back on the homepage, switch the language and return on games.php to see my changes. In the header, I use those lines of code <ul class="nav-lang"> <li><a href="{$currentpagelinkback}language=english" data-lang="en"><img src="templates/{$template}/img/svg/english.svg" class="svg" alt="English" width="24" /> En</a></li> <li><a href="{$currentpagelinkback}language=french" data-lang="en"><img src="templates/{$template}/img/svg/french.svg" class="svg" alt="French" width="24" /> Fr</a></li> <li><a href="{$currentpagelinkback}language=german" data-lang="en"><img src="templates/{$template}/img/svg/german.svg" class="svg" alt="German" width="24" /> De</a></li> </ul> As I say, it works great on defaults .php pages. Here is my custom games.php code (Almost copied all the code explained on the main documentation -> https://developers.whmcs.com/advanced/creating-pages/ ) <?php use WHMCS\Database\Capsule; //define("CLIENTAREA", false); //define("FORCESSL", false); require("init.php"); $ca = new WHMCS_ClientArea(); $ca->setPageTitle("Our games"); $ca->addToBreadCrumb('index.php', Lang::trans('globalsystemname')); $ca->addToBreadCrumb('games.php', 'Our games'); $ca->initPage(); //$ca->requireLogin(); // Uncomment this line to require a login to access this page # To assign variables to the template system use the following syntax. # These can then be referenced using {$variablename} in the template. $games = array(); foreach (Capsule::table('tblproductgroups')->where('id', '>', '3')->where('hidden', '=', '0')->orderBy('order', 'asc')->get() as $group) { foreach (Capsule::table('tblproducts')->where('gid', '=', $group->id)->get() as $game) { $games[$group->id]['games'][] = $game; } $games[$group->id]['details'] = $group; } $ca->assign('games', $games); Menu::addContext(); Menu::primarySidebar('announcementList'); Menu::secondarySidebar('announcementList'); # Define the template filename to be used without the .tpl extension $ca->setTemplate('games'); $ca->output();
×

Important Information

By using this site, you agree to our Terms of Use & Guidelines