Jump to content

JackRabbit

Level 2 Member
  • Content count

    57
  • Joined

  • Last visited

Community Reputation

10 Good

About JackRabbit

  • Rank
    Level 2 Member
  1. Blank page for new admin account

    Oh, that was the cause of the same problem yesterday.
  2. Smarty Error

    Reinstalling the whmcs admin theme file fixed the problem.
  3. Blank page for new admin account

    Yes, it's actually a different cause but I managed to figure both out just now. The problem with the admin blank page was that I did zip up and ftp a blend customization from my mac. There wasn't a macosx folder in the template folder but after restoring the original blend folder, the problem went away and the activity log said something like "switched admin template from _MACOSX to Blend" - so I could probably figure out why... but I'm done. I just migrated my whm to a new server, updated my whmcs client theme, updated whmcs and installed a new whmcs admin theme all at the same time and now that I've got a few errors here and there, I'm not sure which change I made caused the errors. So next time, one at a time. Anyways, thank you Brian. You're my favorite guy for whmcs problems.
  4. Blank page for new admin account

    Hi Brian, Interesting, I might have zipped up something and unzipped it inside the installation files. I'll do a search. I renamed my old whmcs directory and uploaded a fresh install so that I could copy customizations from the old folder to new.
  5. I've just upgraded my whmcs to the latest version and after creating a new user administrator for whmcs, when logging in with the new user there's just a blank page. the activity log says: Smarty Error: Unable to load template file '__MACOSX/footer.tpl' I'm not sure where the system is configured to look for a file in a _MACOSX directory
  6. Smarty Error

    I've got an error: Fatal error: Uncaught --> Smarty: Unable to load template file '__MACOSX/header.tpl' <-- thrown in /home/revtonic/public_html/jackrabbit/whmcs/vendor/whmcs/whmcs-foundation/lib/Terminus.php on line 0 first few lines of code in the terminus.php file: <?php //00ee8 if(!extension_loaded('ionCube Loader')){$__oc=strtolower(substr(php_uname(),0,3));$__ln='ioncube_loader_'.$__oc.'_'.substr(phpversion(),0,3).(($__oc=='win')?'.dll':'.so');if(function_exists('dl')){@dl($__ln);}if(function_exists('_il_exec')){return _il_exec();}$__ln='/ioncube/'.$__ln;$__oid=$__id=realpath(ini_get('extension_dir'));$__here=dirname(__FILE__);if(strlen($__id)>1&&$__id[1]==':'){$__id=str_replace('\\','/',substr($__id,2));$__here=str_replace('\\','/',substr($__here,2));}$__rd=str_repeat('/..',substr_count($__id,'/')).$__here.'/';$__i=strlen($__rd);while($__i--){if($__rd[$__i]=='/'){$__lp=substr($__rd,0,$__i).$__ln;if(file_exists($__oid.$__lp)){$__ln=$__lp;break;}}}if(function_exists('dl')){@dl($__ln);}}else{die('The file '.__FILE__." is corrupted.\n");}if(function_exists('_il_exec')){return _il_exec();}echo("Site error: the ".(php_sapi_name()=='cli'?'ionCube':'<a href="http://www.ioncube.com">ionCube</a>')." PHP Loader needs to be installed. This is a widely used PHP extension for running ionCube protected PHP code, website security and malware blocking.\n\nPlease visit ".(php_sapi_name()=='cli'?'get-loader.ioncube.com':'<a href="http://get-loader.ioncube.com">get-loader.ioncube.com</a>')." for install assistance.\n\n");exit(199); ?> This error came up after moving to a new host. How can I troubleshoot this?
  7. Using Affiliate Balance to pay Hosting bill

    You've got a good Memory Brian. Ok, I'll see if I can find a good solution and post it here.
  8. Is it possible to somehow use the Affiliate Balance to auto pay for the hosting bill each month? I know I can credit his hosting account and subtract the affiliate balance manually but the problem is that he would have to contact me and remind me each time he wants to do this. It would be much more convenient if he can use his affiliate balance as hosting credit.
  9. Problem solved. My reseller storage was at 100% quota so I was unable to set up another account. After upgrading with my hosting reseller,- module create success. I'm getting so many signups I can't keep up
  10. I'm getting an error: Module Create Failed - Service ID: 126 - Error: Product attribute Package Name "jackrabb_Basic" not found on server This package is inside WHM and has worked consistently for the last 2 years but today it's not working when a new client tried to sign up. How can I fix this? It's urgent, I've got WHMCS through A2 hosting and I don't want to wait for them although I've already submitted a ticket there.
  11. Promotions: once per product

    I've got a big problem here... I've got people signing up and using my "get your first month for $1 and a free domain name" to order the first month for $1 and get a free domain name, however, I can't apply this to each order for once per product. I'm using a price override for $.50 per product ordered so they can get a domain and hosting for $1 total. The problem is that if someone orders using this promotion, they can get multiple domains for $.50 each which causes the client to cost me a lot more money. I need this to only work once per product, eg. use once on a hosting package and once on a domain. Any additional domains or hosting is going to cost normal price. Is this possible? I need an idea about how to go about this using one promotional code.
  12. Stop automatic CC charges

    Hi there, I've installed an addon for Stripe created by Roudiapp. I'm in contact with the developer for this addon so I can relay any info I get from this thread. Here's the problem I'm having: A client asked me to remove her CC so it's not stored in our system. So I removed her profile from stripe and checked the box in her whmcs profile that says "disable automatic cc processing" 2 problems now, she's still getting emails that are telling her "we've tried to process your cc but it was declined" so the system is still trying to bill her automatically (is this sent to her for manually trying to charge WHMCS is declining her credit card, I assume it's because I've got the "disable automatic cc processing" checked. My question is, how can I stop WHMCS from trying to automatically capture the payment when a client asks to pay manually each time?
  13. I've got a promotional code that allows my clients to get a free domain with the hosting package. One client just took advantage of this by getting the free domain (a $30 tld), then immediately canceling the service and tranfering the domain to another service. I need to be able to lock the domain so it's not able to be transfered for 3 full billing cycles when someone uses a certain discount coupon. I've checked the domain tab in the general settings and I didn't see an option to keep the domain lock from appearing in a clients dashboard or to prevent a client from transferring a domain. Inside the admin in a clients profile, is it possible to prevent a client from transferring a domain? Disable the domain lock from showing up in their dashboard? thanks!
  14. Disable invoice reminders only on active subscriptions

    Hi there Brian, Yes, I've made these adjustments in my email templates. I saw this right after I posted this thread and I think this will work just fine. Thanks!
  15. I'm having a huge problem with people setting up a subscription when buying hosting. about half of them are paying again when they get an invoice reminder and I'm sending refunds back like crazy which are costing me fees in paypal. There is no need for an invoice reminder for active subscriptions, how can I disable this only for active subscriptions? I'd like to keep sending invoice reminders for people without active subscriptions and overdue subscriptions so they're reminded to pay manually.
×

Important Information

By using this site, you agree to our Terms of Use & Guidelines