Jump to content

Leaderboard


Popular Content

Showing content with the highest reputation on 05/11/21 in all areas

  1. 1 point
    @Waiting for Approval https://developers.whmcs.com/hooks/module-hooks/ Also be sure that your filename is hooks.php. I wasted lot of time trying to understand why the file myhook.php was working at includes/hooks/ and not at modules/addons/..... I forgot to rename the file to hooks.php As advice: Let your hooks at includes/hooks/. You can change them as many times as you want. The only problem is that if you upload the hook before activating your module, in most cases you'll get database error in public area (if your hook have queries). Chris
  2. 1 point
    We had a similar issue once. A hook for one of our modules wouldn't work on one WHMCS installation but worked fine on the rest of our installations. It was a problem for weeks. At the end, I just left it. It wasn't something critical. While we had the issues, I started developing another module which also used hooks. For some weird reason, this solved our issues with the first module's hooks - despite no changes being made to that module. The two modules didn't even use the same hook events. I still don't know what went wrong. Make sure that the addon is enabled (try disabling and enabling again). Try disabling most of your code in that hook except something line "logActivity('test');".
  3. 1 point
    This change in WHMCS makes things difficult. We have customers who need a new password to access WHMCS, when we perform the reset, the customer says that he did not receive the email or that the reset process does not work (probably the customer does not know how to do it). In short, we have no way to save a password for the customer and providing it by phone, chat or email, the customer has no way to enter the WHMCS to make payments. Honestly, I don't know which brilliant mind thought this change was a good idea. Please, allow admins write a new password for a user.
  4. 1 point
    We had the same problem. We were using a path with a symlink in it. When we changed it to the full path it started working. The other paths in the configuration.php that were using symlinks appeared to be OK, but we have changed them to the full path in case they are affected similarly.
  5. 1 point
    Sounds like the permissions folder might not be set correctly, ensure the permissions are set to /attachments CHMOD 777 Writeable
  6. 1 point
    does your attachments folder have the correct permissions ? http://docs.whmcs.com/Installing_WHMCS if you have moved it, is it's location in the configuration.php file correct? http://docs.whmcs.com/Further_Security_Steps
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use & Guidelines and understand your posts will initially be pre-moderated